summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-02-04 08:50:54 +0100
committerHans de Graaff <graaff@gentoo.org>2023-02-04 08:50:54 +0100
commit5d7ef8d953fb09d25cce4177535b745488d8744d (patch)
treed215e9130679ba377ba0dac89054382dfb1cd93f /dev-ruby
parentdev-ruby/rspec-core: add 3.12.1 (diff)
downloadgentoo-5d7ef8d953fb09d25cce4177535b745488d8744d.tar.gz
gentoo-5d7ef8d953fb09d25cce4177535b745488d8744d.tar.bz2
gentoo-5d7ef8d953fb09d25cce4177535b745488d8744d.zip
Revert "dev-ruby/jwt: drop 2.2.3, 2.3.0, 2.4.0"
This reverts commit 0bf0fa5edf82d511b769ae6e0bc62d6eba77df0b. jwt 2.2.x is still used by app-admin/r10k Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/jwt/Manifest3
-rw-r--r--dev-ruby/jwt/jwt-2.2.3.ebuild35
-rw-r--r--dev-ruby/jwt/jwt-2.3.0.ebuild33
-rw-r--r--dev-ruby/jwt/jwt-2.4.0.ebuild33
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-ruby/jwt/Manifest b/dev-ruby/jwt/Manifest
index c8d913b4a39d..d6050257337e 100644
--- a/dev-ruby/jwt/Manifest
+++ b/dev-ruby/jwt/Manifest
@@ -1,3 +1,6 @@
+DIST jwt-2.2.3.tar.gz 50675 BLAKE2B 904a2b9be80ece10cc046d35df784ecc4991c3b09a79c2e2e461003596e9212409ed5840282ce632d3ff499754c505cd899ca95945f562883869ff3c50c4399a SHA512 ebefbf8f825afc1a78329088012118ed681a61bdf9e1c6a3fa125d46105092f1f26a4bc88791788c0290009dbc0427128d655a301c034ac07caf14216744962c
+DIST jwt-2.3.0.tar.gz 53312 BLAKE2B 4653a786d0f5da0d7c7e160f5b0c189f0eab78d045d5af441561c953d6d42fc74d6baff95e54dd9bfd47b3245f3b628e25f99e37016631ef282d95564a08cb1d SHA512 a4dfbb119575d9b5f883c2789734180f092adc75e05310de2e523e352f47469243868480e06f9bfabfa2a48e174ea669e69bd73e0fd002c4f66134462ffe2653
+DIST jwt-2.4.0.tar.gz 59280 BLAKE2B e7ff827c0f8d0514feaea43f5915d83b4be4ee538890250a390cf9a5df3f372d5bff3d90b741d0024c9e89ad28e581626a330b1fb400d2616454a1f964d358e4 SHA512 2bb409a8b2ae2e2330744e3efe306bfc1755c70244f2d7d4dd8ed824c7960f42baf6ec3ee80ed74c0590a3a61b92f61edb157db001d4c4f28005bb50c60bf74f
DIST jwt-2.4.1.tar.gz 59783 BLAKE2B c18d44f0adda0c2111d312450c01c39d3926afc3e13c807283ffc1fe47b7c49284ab48572b47845c30805c2caefebbdf257e18e807af84819a7fff6c86f881c8 SHA512 871ffe9dc659877a77de0c2a51b1f78b45614cf8265bd07820a9b4b08e38160861b4c9f98391138bfaaf64261ce2eb58eba26c40f29c41b02b8fa16cd260997a
DIST jwt-2.5.0.tar.gz 65165 BLAKE2B 3011bca18101cd6ec4ce066ce541e31d135ca57ecb3c105915e55d1637e4465e5ae87655c4a7dbb91ff8ca299b6b1c77f9c9263b944cb6b90a1679c25a593cc7 SHA512 fab73ee33769db297b8c8c7381070c8fcd1dd8e43aff2d241ee82f0327867eff3c1067536a90928ad65a2870dc2638515617f5d5cc92023ab1dfe3b6696f10d8
DIST jwt-2.6.0.tar.gz 72387 BLAKE2B b20d902625815763b203ee201482792e4db5976a5b7cff24a6c08d391f254d62a80b7d5aa5a6833a50eb3252dd1359c28707da8e6f8d0b43308b8aef6b108687 SHA512 62d62728f97d5ac779919365b144cc5ddb9d2a74b16e1692a6bb37e0a64a89b3990429244694eb1a5e36793c64a179cf2f38738600b721f8d419d6ea13e96caa
diff --git a/dev-ruby/jwt/jwt-2.2.3.ebuild b/dev-ruby/jwt/jwt-2.2.3.ebuild
new file mode 100644
index 000000000000..bed4ee7f5a63
--- /dev/null
+++ b/dev-ruby/jwt/jwt-2.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-jwt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+PATCHES=( "${FILESDIR}/${P}-ec-test.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.start/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/jwt/jwt-2.3.0.ebuild b/dev-ruby/jwt/jwt-2.3.0.ebuild
new file mode 100644
index 000000000000..62bb08bb5f03
--- /dev/null
+++ b/dev-ruby/jwt/jwt-2.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-jwt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.start/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/jwt/jwt-2.4.0.ebuild b/dev-ruby/jwt/jwt-2.4.0.ebuild
new file mode 100644
index 000000000000..2151906e7d9c
--- /dev/null
+++ b/dev-ruby/jwt/jwt-2.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-jwt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.start/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}