summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-16 07:10:04 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-16 08:37:54 +0200
commit61d90c18ff3d9cb6c202841cac10473da8b1f9e7 (patch)
tree6c1d1d98d1c8f7edf1cb7a69798859f7f3fce01b /dev-ruby
parentdev-ruby/tty-screen: initial import of 0.7.0 (diff)
downloadgentoo-61d90c18ff3d9cb6c202841cac10473da8b1f9e7.tar.gz
gentoo-61d90c18ff3d9cb6c202841cac10473da8b1f9e7.tar.bz2
gentoo-61d90c18ff3d9cb6c202841cac10473da8b1f9e7.zip
dev-ruby/tty-cursor: initial import of 0.7.0
Dependency for forthcoming dev-ruby/tty-reader Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tty-cursor/Manifest1
-rw-r--r--dev-ruby/tty-cursor/metadata.xml11
-rw-r--r--dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild24
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/tty-cursor/Manifest b/dev-ruby/tty-cursor/Manifest
new file mode 100644
index 000000000000..301fca50f93e
--- /dev/null
+++ b/dev-ruby/tty-cursor/Manifest
@@ -0,0 +1 @@
+DIST tty-cursor-0.7.0.gem 11776 BLAKE2B 5dea8f2bde63f803639b4300bf3a8b22a89de7a20530ede38f75bdae7fbb522fe70adb0c78e20cc45e8001dba9fb378722f9fce6d26a68c0af00b7bc98a62a96 SHA512 00de195ba183174ebd10da7f1fdbb436a17fe9befc6eacb2d4cf4b1505be2c7d0719c0dc32d75a82900b2252ffbed00219ce31836c442b63c267e26dad40da63
diff --git a/dev-ruby/tty-cursor/metadata.xml b/dev-ruby/tty-cursor/metadata.xml
new file mode 100644
index 000000000000..87a04500289e
--- /dev/null
+++ b/dev-ruby/tty-cursor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">piotrmurach/tty-cursor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild b/dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild
new file mode 100644
index 000000000000..560f169fc107
--- /dev/null
+++ b/dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Move the terminal cursor around and manipulate text using intuitive method calls"
+HOMEPAGE="https://github.com/piotrmurach/tty-cursor"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}