summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-01-03 08:39:29 +0100
committerHans de Graaff <graaff@gentoo.org>2021-01-03 09:05:24 +0100
commit6a8d65f38d777b7e8cb6cc3adea1634ed5165f11 (patch)
tree4dd49f92c913115c6bc770802e8687855a146cca /dev-ruby
parentdev-ruby/ruby-oembed: add 0.15.0 (diff)
downloadgentoo-6a8d65f38d777b7e8cb6cc3adea1634ed5165f11.tar.gz
gentoo-6a8d65f38d777b7e8cb6cc3adea1634ed5165f11.tar.bz2
gentoo-6a8d65f38d777b7e8cb6cc3adea1634ed5165f11.zip
dev-ruby/ruby-progressbar: add 1.11.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-progressbar/Manifest1
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.11.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/Manifest b/dev-ruby/ruby-progressbar/Manifest
index 6c56a8cb73e8..de30f3165066 100644
--- a/dev-ruby/ruby-progressbar/Manifest
+++ b/dev-ruby/ruby-progressbar/Manifest
@@ -1 +1,2 @@
DIST ruby-progressbar-1.10.1.tar.gz 53416 BLAKE2B ee435291cd55558843ab05254c01a6148711aee54a5ce80d7b03902e32fd8735fda2e3686794f3f2c8a62c7ca26d90df4d63b48c8d947a471279c35131c49898 SHA512 6cbd791833a1638949c7283b5c475164b44ec8a5d4c7eb417d741da5c9cda9e777481a785f112be7fd1c3714668ad58cbf9aa39eecb61d1022fb3bb35ddb6203
+DIST ruby-progressbar-1.11.0.tar.gz 61341 BLAKE2B 558de9d15f6c3eafb0a9ef0b39db279727651c8f86234f3ffad1faac7e9ab7f6bdef6662fadb2132bf10d70bcac9412801a695e0bb3afa5879a48dd363920734 SHA512 5a5c8a6af410746ef601821ec171933d781d32bfb7cb5f67f9cf877824a399941c11be69bb74380941f2271f6f5139928599881441f88860a71f8b7f7b55d4b4
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.11.0.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.11.0.ebuild
new file mode 100644
index 000000000000..75257d96de15
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.11.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="ruby-progressbar.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+}