summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-09-09 16:25:28 -0700
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-28 18:19:33 +0200
commit7064ce8445708517ce780eeec77b98c0278839e1 (patch)
treeca1e16ce95441e36b4188b0ccdc5311d835283fc /dev-ruby
parentmedia-gfx/openscad: Needs rebuild on cgal subslot bump (diff)
downloadgentoo-7064ce8445708517ce780eeec77b98c0278839e1.tar.gz
gentoo-7064ce8445708517ce780eeec77b98c0278839e1.tar.bz2
gentoo-7064ce8445708517ce780eeec77b98c0278839e1.zip
dev-ruby/msgpack: add ruby24 to USE_RUBY
drop ruby21 from USE_RUBY Closes: https://github.com/gentoo/gentoo/pull/5676
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/msgpack/msgpack-1.1.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/msgpack/msgpack-1.1.0-r1.ebuild b/dev-ruby/msgpack/msgpack-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..dd26691671f2
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-1.1.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="https://msgpack.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove jruby-specific specs that are run also for other rubies.
+ rm -rf spec/jruby || die
+
+ sed -i -e '/git ls-files/d' msgpack.gemspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
+
+ # rb_num2int is not inlined on 32 bit arches but also not explicitly
+ # defined, bug 582968
+ sed -i -e 's:-Wl,--no-undefined::' ext/${PN}/Makefile || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
+}