summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-05-23 07:03:28 +0200
committerHans de Graaff <graaff@gentoo.org>2019-05-23 07:38:47 +0200
commit7adccfb52609bf91481ed351c7b91dc1daf7e13b (patch)
tree1f02c4b723b697be88a4b4875a81ce8cd63e9a8e /dev-ruby
parentdev-ruby/barby: add 0.6.7 (diff)
downloadgentoo-7adccfb52609bf91481ed351c7b91dc1daf7e13b.tar.gz
gentoo-7adccfb52609bf91481ed351c7b91dc1daf7e13b.tar.bz2
gentoo-7adccfb52609bf91481ed351c7b91dc1daf7e13b.zip
dev-ruby/patron: add 0.13.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/patron/Manifest1
-rw-r--r--dev-ruby/patron/patron-0.13.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/patron/Manifest b/dev-ruby/patron/Manifest
index 5c5faffddb27..b22add4d380b 100644
--- a/dev-ruby/patron/Manifest
+++ b/dev-ruby/patron/Manifest
@@ -1 +1,2 @@
DIST patron-0.13.1.gem 64512 BLAKE2B 14f691cb0fd1c863a1ef634ba8aee94751095138e940f13bf09860e9e0061872fe14fa33416f59f82d4adc53963721d653936a3f058b27654ea7593d6068d0b7 SHA512 7b082ff7442c2635c38b37132cd61f6cd18d4792d41cbf3bed1201fb7371b75bb628a295f4e3dd173c23e086d3c1f54f0217df3f7d1a30c1031fcca86269e1e7
+DIST patron-0.13.3.gem 65024 BLAKE2B 87aa69aab49978d14a80ed9e09d74d7853da3512875cc3aecd3f387d1523b85c84625b57a5826e5f5f999cec4feaae58c1aaae96582144a5c9dc537c9d5a4224 SHA512 afbbbd9570e338a5d1b97b4ebeda76ac95a22c29d908629723d345a47400183c2ccee67ebcaf5b6f9ecb032eb3b847e70ec9eebff75b33045a3665c215abfbd0
diff --git a/dev-ruby/patron/patron-0.13.3.ebuild b/dev-ruby/patron/patron-0.13.3.ebuild
new file mode 100644
index 000000000000..cedf0130468e
--- /dev/null
+++ b/dev-ruby/patron/patron-0.13.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="https://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+ruby_add_bdepend "test? ( www-servers/puma )"
+
+all_ruby_prepare() {
+ # Fix Rakefile
+ sed -i -e 's:rake/rdoctask:rdoc/task:' \
+ -e 's/README.txt/README.md/' \
+ -e '/bundler/I s:^:#:' \
+ -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' \
+ Rakefile || die
+
+ # Avoid specs with failures. We were not running any specs before.
+ rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}