summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-24 05:43:08 +0000
committerSam James <sam@gentoo.org>2022-12-24 06:31:51 +0000
commit832afd7ae658f16851fa0f31c151e5ad5f5ea1a9 (patch)
tree80a1665bc45900402422d06e2e70d2f15f3442d7 /dev-ruby
parentdev-ruby/faraday-net_http: drop ruby26, enable ruby31 (diff)
downloadgentoo-832afd7ae658f16851fa0f31c151e5ad5f5ea1a9.tar.gz
gentoo-832afd7ae658f16851fa0f31c151e5ad5f5ea1a9.tar.bz2
gentoo-832afd7ae658f16851fa0f31c151e5ad5f5ea1a9.zip
dev-ruby/typhoeus: fix faraday test dep
The second option in || ( A B ) had no slot, so it allowed Faraday 2, even though it's not supported. Change to :0 as a minimal change to make it correct, although we could just drop it as :0 is masked now. Without this, faraday 1.x is not pulled in, just faraday 2, and we get ``` [...] Gem::MissingSpecVersionError: Could not find 'faraday' (< 2) - did find: [faraday-2.7.2] ``` on tests. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild b/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild
index 115b05f2878c..b6c62ee9b3be 100644
--- a/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild
+++ b/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild
@@ -23,7 +23,7 @@ IUSE=""
ruby_add_rdepend ">=dev-ruby/ethon-0.9.0"
-ruby_add_bdepend "test? ( dev-ruby/json || ( dev-ruby/faraday:1 >=dev-ruby/faraday-0.9 ) >=dev-ruby/sinatra-1.3 >=dev-ruby/redis-3.0 >=dev-ruby/dalli-2.7.9 )"
+ruby_add_bdepend "test? ( dev-ruby/json || ( dev-ruby/faraday:1 >=dev-ruby/faraday-0.9:0 ) >=dev-ruby/sinatra-1.3 >=dev-ruby/redis-3.0 >=dev-ruby/dalli-2.7.9 )"
all_ruby_prepare() {
sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die