summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-09-05 06:59:34 +0200
committerHans de Graaff <graaff@gentoo.org>2017-09-05 08:21:49 +0200
commit854dd75609afcf51464bfb583ef5d9bf7f3c7e5e (patch)
tree4eb4766011e25460d7b34a66c1a2bc63a2e5361c /dev-ruby
parentmedia-libs/mesa: Restore stable 17.0.6 version (diff)
downloadgentoo-854dd75609afcf51464bfb583ef5d9bf7f3c7e5e.tar.gz
gentoo-854dd75609afcf51464bfb583ef5d9bf7f3c7e5e.tar.bz2
gentoo-854dd75609afcf51464bfb583ef5d9bf7f3c7e5e.zip
dev-ruby/multi_json: add 1.12.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/multi_json/Manifest1
-rw-r--r--dev-ruby/multi_json/multi_json-1.12.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/multi_json/Manifest b/dev-ruby/multi_json/Manifest
index 305adf614de7..1ed41a6e02a2 100644
--- a/dev-ruby/multi_json/Manifest
+++ b/dev-ruby/multi_json/Manifest
@@ -1,2 +1,3 @@
DIST multi_json-1.12.1.tar.gz 25579 SHA256 1ec98fd529284e99cd6156509542ccd290cfdd5bce03910ceed5127bb84cbb42 SHA512 f61e500197c5a1373443b308bd9307238c54d2d23ba9da91843c667c12e491f34fd87575028c3630a81a7355d4903344996f20408bbb7971b12dfba3cc4f76df WHIRLPOOL 93152310d15ca126960814c53a24d8d1e7c6241eaabc913f88f1485451eaed70288d8c7e5b7a19260f73e2a25de17b95c46fb15c16e7758980b79a48be53b498
+DIST multi_json-1.12.2.tar.gz 25630 SHA256 1d5c51ea6ce8b4ead8c93964104e4935896452430e9209476550c57839abb3ad SHA512 bbbdd05a6dd12052aa3e09389f47212f15799310d5c265057f7ca801622d32295d1f0844b37e51f8f1fd2d48e4430234f99bc6de4b9ed149e81d9a33a831e6d9 WHIRLPOOL 6a550c7ccb3e234a12a42418048ad45c5abfc7aad1be56a13e9fea9b66c4864574e38cec69e2d184f46fdeece5cce8e1aa227dc69e9f3de6689f70cc44e22672
DIST multi_json-1.9.3.gem 30720 SHA256 631390d4b6c3d3753a3df0c28339c8e7840704083dfdcefb1323a22ab97b2281 SHA512 7f06747e760a63b6421dfda480522924f12bd00ad63f95414f6624173b9b9b255b139f9dc33d2d2a8d19b232f99a005033e00e3a0b223be992f73d142a55b8b5 WHIRLPOOL a96f1c1e53865e153bc83079fc70b69af6c941c4995f4215317ca53567532d1406adb174683fc8c5229fdc3563f5e8d3c2c662d77cf9d9d55367aab2df5b34f0
diff --git a/dev-ruby/multi_json/multi_json-1.12.2.ebuild b/dev-ruby/multi_json/multi_json-1.12.2.ebuild
new file mode 100644
index 000000000000..28c6df523881
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.12.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/intridea/multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="https://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-1.0 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:3 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json
+ dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
+ -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
+ -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
+ -e '/using one-shot parser/,/^ end/ s:^:#:' \
+ spec/multi_json_spec.rb
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+ # Avoid testing unpackaged adapters
+ rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_test() {
+ for t in spec/*_spec.rb; do
+ ${RUBY} -S rspec-3 ${t} || die
+ done
+}