summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-11-06 09:20:56 +0100
committerHans de Graaff <graaff@gentoo.org>2020-11-06 09:21:11 +0100
commit87990eb3a19c77df170884b3364c03991bb3c9c4 (patch)
tree4168cf26d73f9e0206d606b0a7047217c650aaaf /dev-ruby
parentdev-python/python-email-validator: Bump to 1.1.2 (diff)
downloadgentoo-87990eb3a19c77df170884b3364c03991bb3c9c4.tar.gz
gentoo-87990eb3a19c77df170884b3364c03991bb3c9c4.tar.bz2
gentoo-87990eb3a19c77df170884b3364c03991bb3c9c4.zip
dev-ruby/asciidoctor: add 2.0.11
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/asciidoctor/Manifest1
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-2.0.11.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/Manifest b/dev-ruby/asciidoctor/Manifest
index 9eda14ef6e65..460b6bb6301b 100644
--- a/dev-ruby/asciidoctor/Manifest
+++ b/dev-ruby/asciidoctor/Manifest
@@ -1 +1,2 @@
DIST asciidoctor-2.0.10.tar.gz 613180 BLAKE2B 46125c85276eb0c7cf4404ca04d854449233e2cd14e24687aed9f95eb64ceb6ebac3d3ed73918679b9a5b047e41d82d02383d0e08acd0df5cc9bc216f14c79a3 SHA512 9ef908081569188d9903c7a7619fe0b50197f6f0cc922c4070e116bcd3f988a55da87443e84b6e260aabcc653a804fcaf29b96a722ab36f7ebb27ec11eb7ddbe
+DIST asciidoctor-2.0.11.tar.gz 625446 BLAKE2B 4c4a3a7e019971765efade92da39d5895f54bd3eb927eb1ecc1cc3e3998490fcdb93426c03c9fca82d777b28c6c8027f34d39289b2250254884613670eacf9d6 SHA512 eef126653fb75c4d4bce5481f9e12f1852cf5794f547e1131f2e3f5bc34c3813e32034e6890432e83fc543b4a5dcca46750d052844d7055bfe20ea4b0c4428f2
diff --git a/dev-ruby/asciidoctor/asciidoctor-2.0.11.ebuild b/dev-ruby/asciidoctor/asciidoctor-2.0.11.ebuild
new file mode 100644
index 000000000000..15d529af89d7
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-2.0.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="test features"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/concurrent-ruby
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/rouge
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}