summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-02-19 18:35:55 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-02-19 18:37:11 -0600
commit91f02c9869957da3a2b8587c2058f07c915cca4c (patch)
tree3e81500e224680d19ef52deb85aedd5cb85e02ce /dev-ruby
parentapp-admin/ansible: 2.10.6 bump 2.10.5 stable amd64/arm64/x86 (diff)
downloadgentoo-91f02c9869957da3a2b8587c2058f07c915cca4c.tar.gz
gentoo-91f02c9869957da3a2b8587c2058f07c915cca4c.tar.bz2
gentoo-91f02c9869957da3a2b8587c2058f07c915cca4c.zip
dev-ruby/facter: 3.14.16-r1 stable amd64/x86 with cleanup
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/facter/Manifest2
-rw-r--r--dev-ruby/facter/facter-3.14.14.ebuild99
-rw-r--r--dev-ruby/facter/facter-3.14.15.ebuild99
-rw-r--r--dev-ruby/facter/facter-3.14.16-r1.ebuild2
4 files changed, 1 insertions, 201 deletions
diff --git a/dev-ruby/facter/Manifest b/dev-ruby/facter/Manifest
index 21f5e7616934..3f503ed37f7d 100644
--- a/dev-ruby/facter/Manifest
+++ b/dev-ruby/facter/Manifest
@@ -1,3 +1 @@
-DIST facter-3.14.14.tar.gz 407276 BLAKE2B 5f911581773ef9a19ee42b5ed64114e2519ff88e024490d74bf9b1e777221d92d3ed502c8e6a0df573a5390fca323fcf0bcfdce6aeed25826c84efb3971307a5 SHA512 22e0ff0a9280be129f7587e24109f76f34660d99086378dd7e9ccc004c08a4fa5dd6f9ba50957c146ea40e26344ee87dbafd45b885f8f576192b6e572b084af7
-DIST facter-3.14.15.tar.gz 407293 BLAKE2B 0f9bfe78314144e920695e678fa7ce8b4656ba424240e7e7621fe048e15e46db6fe507bc859448fa22f31e28caecadc33877ebaee8dab85c8e87238daf140157 SHA512 45deb530991883ecb1235d6a6166c36888c3c2c4a42a694e041f4d0911ab4bed880bee56034871fde08cc723b7270166e7d0dfa626bbc205d3b1f495c8d74691
DIST facter-3.14.16.tar.gz 407315 BLAKE2B f9637841bd2c1d369d262c77876f08bb248f6a98e0fcb10573c872d521473790ba6eaa8dfcd6a8f0da2becd2f10c2bc7fbfde0d3a44f6a3d38c9e5f363e27e66 SHA512 3adcb7c3ce90a9cb71486c5d86eeaf1f0794194f51faf149052333d2f55a8a8fbe1e5772ecf9a0ed53196cfe732effeb383a42a43942a7803aa8b27e23939d23
diff --git a/dev-ruby/facter/facter-3.14.14.ebuild b/dev-ruby/facter/facter-3.14.14.ebuild
deleted file mode 100644
index f2b40c9e3b70..000000000000
--- a/dev-ruby/facter/facter-3.14.14.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake-utils eutils ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
- EGIT_BRANCH="master"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
- SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-RESTRICT="!test? ( test )"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="
- >=dev-cpp/cpp-hocon-0.2.1:=
- >=dev-libs/leatherman-1.0.0:=
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- dev-libs/boost:=[nls]
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-DEPEND="${RDEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.14.6-fix-static-libcpp-hocon.patch
- # be explicit about the version of rspec we test with
- "${FILESDIR}"/${PN}-3.14.8-explicit-rspec-2.patch
-)
-
-pkg_setup() {
- ruby-ng_pkg_setup
-}
-
-src_unpack() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-}
-
-each_ruby_configure() {
- # hack for correct calculation of relative path from facter.rb to
- # libfacter.so
- my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- local mycmakeargs=(
- -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
- -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- addpredict /proc/self/oom_score_adj
- cmake-utils_src_compile
-}
-
-src_test() {
- cmake-utils_src_test
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
- cmake-utils_src_install
- ruby-ng_src_install
-}
diff --git a/dev-ruby/facter/facter-3.14.15.ebuild b/dev-ruby/facter/facter-3.14.15.ebuild
deleted file mode 100644
index 0feb8baceeec..000000000000
--- a/dev-ruby/facter/facter-3.14.15.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake-utils eutils ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
- EGIT_BRANCH="master"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
- SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-RESTRICT="!test? ( test )"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="
- >=dev-cpp/cpp-hocon-0.2.1:=
- >=dev-libs/leatherman-1.0.0:=
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- dev-libs/boost:=[nls]
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-DEPEND="${RDEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.14.6-fix-static-libcpp-hocon.patch
- # be explicit about the version of rspec we test with
- "${FILESDIR}"/${PN}-3.14.8-explicit-rspec-2.patch
-)
-
-pkg_setup() {
- ruby-ng_pkg_setup
-}
-
-src_unpack() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-}
-
-each_ruby_configure() {
- # hack for correct calculation of relative path from facter.rb to
- # libfacter.so
- my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- local mycmakeargs=(
- -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
- -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- addpredict /proc/self/oom_score_adj
- cmake-utils_src_compile
-}
-
-src_test() {
- cmake-utils_src_test
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
- cmake-utils_src_install
- ruby-ng_src_install
-}
diff --git a/dev-ruby/facter/facter-3.14.16-r1.ebuild b/dev-ruby/facter/facter-3.14.16-r1.ebuild
index 249ddd7569a6..b69eea0e499e 100644
--- a/dev-ruby/facter/facter-3.14.16-r1.ebuild
+++ b/dev-ruby/facter/facter-3.14.16-r1.ebuild
@@ -19,7 +19,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_BRANCH="master"
else
[[ "${PV}" = *_rc* ]] || \
- KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi