summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-08-21 08:20:24 +0200
committerHans de Graaff <graaff@gentoo.org>2020-08-21 08:51:11 +0200
commit9ecb4a6bd29603da462b8d80f70c7fc898e1f84e (patch)
tree778217ec34e44e7d64131a7e099037c7c8456ab7 /dev-ruby
parentdev-ruby/autoprefixer-rails: add 9.8.6.2 (diff)
downloadgentoo-9ecb4a6bd29603da462b8d80f70c7fc898e1f84e.tar.gz
gentoo-9ecb4a6bd29603da462b8d80f70c7fc898e1f84e.tar.bz2
gentoo-9ecb4a6bd29603da462b8d80f70c7fc898e1f84e.zip
dev-ruby/globalid: add ruby27
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/globalid/globalid-0.4.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/globalid/globalid-0.4.2-r1.ebuild b/dev-ruby/globalid/globalid-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..8f763248a10f
--- /dev/null
+++ b/dev-ruby/globalid/globalid-0.4.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="globalid.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Reference models by URI"
+HOMEPAGE="https://github.com/rails/globalid"
+SRC_URI="https://github.com/rails/globalid/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler >=dev-ruby/activemodel-4.2.0 >=dev-ruby/railties-4.2.0 )"
+ruby_add_rdepend ">=dev-ruby/activesupport-4.2.0:*"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+
+ sed -i -e '2irequire "forwardable"' test/helper.rb || die
+}