summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-05-27 07:15:53 +0200
committerHans de Graaff <graaff@gentoo.org>2017-05-27 07:15:53 +0200
commit9faf307d33060d4e0681cd08c7958a98d91f38d6 (patch)
tree3d6d521c68086674bb8d6f9ee59d25d6746e7eef /dev-ruby
parentRevert "dev-lang/ruby: fix stack scavenge crash on ia64, bug #561780" (diff)
downloadgentoo-9faf307d33060d4e0681cd08c7958a98d91f38d6.tar.gz
gentoo-9faf307d33060d4e0681cd08c7958a98d91f38d6.tar.bz2
gentoo-9faf307d33060d4e0681cd08c7958a98d91f38d6.zip
dev-ruby/slop: add 4.5.0
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/slop/Manifest1
-rw-r--r--dev-ruby/slop/slop-4.5.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/slop/Manifest b/dev-ruby/slop/Manifest
index eb310c41c93c..dd9ba9477605 100644
--- a/dev-ruby/slop/Manifest
+++ b/dev-ruby/slop/Manifest
@@ -1,3 +1,4 @@
DIST slop-3.6.0.tgz 19570 SHA256 8fdb0e81e0636f7a266b5f12e1fa419c27bf1b529f0c48addaaa9b02bcccf1ca SHA512 48bc2f56070a6f65b865b76dd5ba2e0e434c2ac5f9efef89301833746c0d01e5d9769ae02cdff8a4cfb0ed67d4306d921eafe086f49dafa0af8521d14bcee2a6 WHIRLPOOL c33dfb201a24c07e3abc56fa5c0944caff55814ac42d462e607a63c7d60e7fb02ba80accd020f572331c0bd9abd823446538e81b8039fdf5bab6bfa26d24e5d4
DIST slop-4.4.1.tgz 14506 SHA256 0a936bbc6b21cd2d2a5c2ec6448b3151fe7023d71cc124258877e2d31caa15a9 SHA512 fc0675ee82664195823e5fe465d0812324722b1ecf8d998e13cdcd2cafa7f5ddab3b10b2912ecaf6213f44edfb8baa09e6437596bd4a9a3d7d329efa52bcfc1e WHIRLPOOL ae2ac799ad47fa2991f8baf668515fafe425a5e1adc71474ffbd0fbfd85f369d908edba20478a24d930f53106187ec30e0febc0baf446d1a7d5ce9d1bddff201
DIST slop-4.4.3.tgz 14763 SHA256 acc1d2886803bb019c969bb1fb5779008bdf61ef52238063746eb4c431766906 SHA512 ef34bde9a11734b833270a7a2e5e41996c448d02ab4af37950abfd053c817d1075f0ec2fb8068642d784e2e285b9cba9d6e002f97a1a84cc7dba84a319624544 WHIRLPOOL 99a21667a2571d15e33685c7ae256c22c21cff2c86c1f4240d1bcf24eaef53e9dd5acdc192042a9a3b54c6779b4f72b97120b1f050008974c16fc64fcfb201a6
+DIST slop-4.5.0.tgz 14916 SHA256 15192a0e685181e89a14209e5788a9d4cecbf1c5e6836bd1b953e9a87c8a5d73 SHA512 bef70f384ffb55fe9c1610a0c15af625966772a1525b4c81ca08f943f8455e0180af1a4028e3c34044084537544e34a3b400bf0d3587235c4362e7ea6048992a WHIRLPOOL 810dc2e62dd89a4ca512a65a3d8acf6a197d60a9248677e7b1aff98e540b856fa5e9c1419a8dd3556b9c9d525398cc817532467e17a24b28b3d672437a580843
diff --git a/dev-ruby/slop/slop-4.5.0.ebuild b/dev-ruby/slop/slop-4.5.0.ebuild
new file mode 100644
index 000000000000..2ac06d921083
--- /dev/null
+++ b/dev-ruby/slop/slop-4.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}