summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-09 07:07:37 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-09 07:07:37 +0100
commita572a8ef95ff3528761feb2c84696160f965643e (patch)
tree30c742bd53e7697b202d667a1242146012f6c16c /dev-ruby
parentnet-analyzer/mrtg: Secure HOMEPAGE/SRC_URI. (diff)
downloadgentoo-a572a8ef95ff3528761feb2c84696160f965643e.tar.gz
gentoo-a572a8ef95ff3528761feb2c84696160f965643e.tar.bz2
gentoo-a572a8ef95ff3528761feb2c84696160f965643e.zip
dev-ruby/multi_json: add 1.13.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/multi_json/Manifest1
-rw-r--r--dev-ruby/multi_json/multi_json-1.13.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/multi_json/Manifest b/dev-ruby/multi_json/Manifest
index 05418de8830c..9f288583a2e0 100644
--- a/dev-ruby/multi_json/Manifest
+++ b/dev-ruby/multi_json/Manifest
@@ -1,2 +1,3 @@
DIST multi_json-1.12.1.tar.gz 25579 BLAKE2B 50fa37b907289b8247ffff1e22ebde1b07ee32e5ca97984be1243340f14185ebaaeb72cb28a18c5c77b1b48bfd0b400479fe7ef532e40cef3736d782c84c0d09 SHA512 f61e500197c5a1373443b308bd9307238c54d2d23ba9da91843c667c12e491f34fd87575028c3630a81a7355d4903344996f20408bbb7971b12dfba3cc4f76df
DIST multi_json-1.12.2.tar.gz 25630 BLAKE2B 61209dc4be50b44302cfe40e45b840ae8d81e827d8b9df82ca6b852a72d360fbe09c0f5b0ef8eecfbd08b6bd08343ab7bb307d91d9abf28c9b9adb35f18bea51 SHA512 bbbdd05a6dd12052aa3e09389f47212f15799310d5c265057f7ca801622d32295d1f0844b37e51f8f1fd2d48e4430234f99bc6de4b9ed149e81d9a33a831e6d9
+DIST multi_json-1.13.0.tar.gz 25954 BLAKE2B 22a2f2ff2f1291a45613f456661a1735fc41ad80f28ee7d2c9b97109f0637da4e60439686cfc29b7ced501c32d2fe9236c9acc25acc0f55e57ec0bfe53331f37 SHA512 b168b2a093865f48f1a4d1941e8cfead8b3efba73bcd59660dae581a77ab7149f0f452f1280e69061187f35c84b6eeff70144f815f9f669db03dba49100143aa
diff --git a/dev-ruby/multi_json/multi_json-1.13.0.ebuild b/dev-ruby/multi_json/multi_json-1.13.0.ebuild
new file mode 100644
index 000000000000..819f95007369
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.13.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/intridea/multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="https://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4:* >=dev-ruby/yajl-ruby-1.0 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:3 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json
+ dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
+ -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
+ -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
+ -e '/using one-shot parser/,/^ end/ s:^:#:' \
+ spec/multi_json_spec.rb
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+ # Avoid testing unpackaged adapters
+ rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_test() {
+ for t in spec/*_spec.rb; do
+ ${RUBY} -S rspec-3 ${t} || die
+ done
+}