summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-10-28 06:23:33 +0100
committerHans de Graaff <graaff@gentoo.org>2015-10-28 06:31:02 +0100
commitb44bd815b655f9f5e3e0eb9a9e69890977380c72 (patch)
tree3b386a076163b177c790cac228764b599fd6468b /dev-ruby
parentdev-ruby/jwt: cleanup (diff)
downloadgentoo-b44bd815b655f9f5e3e0eb9a9e69890977380c72.tar.gz
gentoo-b44bd815b655f9f5e3e0eb9a9e69890977380c72.tar.bz2
gentoo-b44bd815b655f9f5e3e0eb9a9e69890977380c72.zip
dev-ruby/jwt: add 1.5.2
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/jwt/Manifest1
-rw-r--r--dev-ruby/jwt/jwt-1.5.2.ebuild30
-rw-r--r--dev-ruby/jwt/metadata.xml2
3 files changed, 32 insertions, 1 deletions
diff --git a/dev-ruby/jwt/Manifest b/dev-ruby/jwt/Manifest
index a90ad99bfe47..48519ce9771f 100644
--- a/dev-ruby/jwt/Manifest
+++ b/dev-ruby/jwt/Manifest
@@ -1 +1,2 @@
DIST jwt-1.5.1.gem 12288 SHA256 d3d39adde503148c2f35eb37d4b0ef3da85fc0b295ee339b59b6d76c2763658d SHA512 a0ea17ce11046041316a9dcad63bf5af3b501d257716398cd23b50ea72ecb04f82670552246f71e9731a2a92429f7652d0ad5944ea97e4a9a6e98f612fecbf0e WHIRLPOOL b845fed75bb5403d721cb5b60cb097942988187e620314a79bc011855e767499b1a53a6df354c36d1901a857c70e48a756dd13f4f5491b5a9a2618e9ca8f0660
+DIST jwt-1.5.2.tar.gz 21131 SHA256 6e628b77e541929f13118344e57511ca9dc08de7dcaf0dc0b6dc5dd3793faeb5 SHA512 9b56bf1fad65318f4c6a6d3bb09bad2ac2661704e4d0ae01eaac5b71bf0486abba573536afa1fa0f00b2b68ea445350f723ac5b73319b238c4d69f10b21d0773 WHIRLPOOL 87a9881eef08b15fdf1295543d332465280d56340d371b021c16663f2d6788944638bf4c9560f3d2f4b6982a105986d59824c0491c64ad40120e52ce252d1b88
diff --git a/dev-ruby/jwt/jwt-1.5.2.ebuild b/dev-ruby/jwt/jwt-1.5.2.ebuild
new file mode 100644
index 000000000000..c209bd695811
--- /dev/null
+++ b/dev-ruby/jwt/jwt-1.5.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${P}"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.configure/,/^end/ s:^:#:' \
+ -e '/codeclimate/I s:^:#:' \
+ spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/jwt/metadata.xml b/dev-ruby/jwt/metadata.xml
index 2aa194a2f228..b18dbe23253b 100644
--- a/dev-ruby/jwt/metadata.xml
+++ b/dev-ruby/jwt/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>ruby</herd>
<upstream>
- <remote-id type="github">progrium/ruby-jwt</remote-id>
+ <remote-id type="github">jwt/ruby-jwt</remote-id>
</upstream>
</pkgmetadata>