summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-08-10 06:09:39 +0200
committerHans de Graaff <graaff@gentoo.org>2020-08-10 06:09:39 +0200
commitc098ee6f67676a2736aaa61e50ef26e32eef8249 (patch)
tree94a7d1091c4bcdd9491c3971bcfcfc61ae529002 /dev-ruby
parentdev-ruby/rdiscount: add 2.2.0.2 (diff)
downloadgentoo-c098ee6f67676a2736aaa61e50ef26e32eef8249.tar.gz
gentoo-c098ee6f67676a2736aaa61e50ef26e32eef8249.tar.bz2
gentoo-c098ee6f67676a2736aaa61e50ef26e32eef8249.zip
dev-ruby/tty-color: add 0.5.2
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tty-color/Manifest1
-rw-r--r--dev-ruby/tty-color/tty-color-0.5.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/tty-color/Manifest b/dev-ruby/tty-color/Manifest
index cc0d55374526..5db5b9ba51a4 100644
--- a/dev-ruby/tty-color/Manifest
+++ b/dev-ruby/tty-color/Manifest
@@ -1,3 +1,4 @@
DIST tty-color-0.4.3.gem 11776 BLAKE2B 4e51a41fb97b343c22a6ae832a449905fc215b7e218a31c993a47c66c66c049f70ce0da163d27f593309c6e49c014badc378ea89dec42c94ce6ba9e088798952 SHA512 4447c02f9b738f4fbecc14149d6c09da2da36c489d118f7d18b85f48b9c22b7939e5c62a32048f1a0c958533be15ead3952c72ea03fd1d06b23b1ed29beadcd8
DIST tty-color-0.5.0.gem 11776 BLAKE2B fc22689783c86b5d18bd3134b198b2bdf50563bc14a25b8a02611ac6a46f494c86b17ff1307089a87ad92442d99da3d408b4907b83f3c67f495a66ceaaddc2ee SHA512 998da9196055b011edf8b20595e548447d7a3cda3555a61c2645dac618dcebf8fcd3b257ae8948f93fd7720956f6dc2b554fb5521a8847017c4a2ab2e2b74e73
DIST tty-color-0.5.1.tar.gz 10877 BLAKE2B 9ae72b4885ea1662038b6c98c672a349c458efb9b07747f2a1d2dfe69070efa08e45ae2fbaa513bbb8e7a9bee5a8a68a2b980456d64894df8556a4a6820b3770 SHA512 48144ef358cf04a4e88b0ee1cf96586c6c9a5d2862a7ea2a4fdcb92853c7b520d2cc94919b6dee97d9bf0384fa5bb9d8e0665730a9965de8b93af1edf459ebff
+DIST tty-color-0.5.2.tar.gz 11437 BLAKE2B a123a46f855a3c5b2c56b658ba9dd1987ce2e72684cfd2e673337de1ab802d28ae00fd9c5e761014314999c5590e2466a32c64a1b094dcfc3101a3754458ea10 SHA512 767566786d1d676bd1571f2cc040107ffc9532219bcff594acaac9ccf972d335cbb1838017e23fa3e32264e9e48f57b818690747e617851c43b3f7e37d2648eb
diff --git a/dev-ruby/tty-color/tty-color-0.5.2.ebuild b/dev-ruby/tty-color/tty-color-0.5.2.ebuild
new file mode 100644
index 000000000000..26f62942b75c
--- /dev/null
+++ b/dev-ruby/tty-color/tty-color-0.5.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tty-color.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal color capabilities detection"
+HOMEPAGE="https://github.com/piotrmurach/tty-color"
+SRC_URI="https://github.com/piotrmurach/tty-color/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+
+ sed -i -e 's:require_relative ":require "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}