summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-05-26 08:19:15 +0200
committerHans de Graaff <graaff@gentoo.org>2017-05-26 08:19:15 +0200
commitc18966fd50785b2c4fc3c2c5f983f8cd81f89432 (patch)
tree76e946db6b228fb7a40fb142ad7bb0078cd60000 /dev-ruby
parentdev-ruby/hitimes: add 1.2.5 (diff)
downloadgentoo-c18966fd50785b2c4fc3c2c5f983f8cd81f89432.tar.gz
gentoo-c18966fd50785b2c4fc3c2c5f983f8cd81f89432.tar.bz2
gentoo-c18966fd50785b2c4fc3c2c5f983f8cd81f89432.zip
dev-ruby/xpath: add 2.1.0
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/xpath/Manifest1
-rw-r--r--dev-ruby/xpath/xpath-2.1.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/xpath/Manifest b/dev-ruby/xpath/Manifest
index 66569f2c0e58..ef8c39cddda1 100644
--- a/dev-ruby/xpath/Manifest
+++ b/dev-ruby/xpath/Manifest
@@ -1,2 +1,3 @@
DIST xpath-0.1.4.gem 13824 SHA256 60a1363643edb3b3802fa1d7c5a042fed0f8f5f5589ed308a47f099ef5dcbf6f SHA512 7764dadf1d63607a5091790b6525242fb293abba01b85bf3bbded9e1ca668d2ebf6af523a84c46de423ad3340af07fbec5cadce59a9c3917d082593309df8aab WHIRLPOOL 270e8109c8c1c91fb50a86d8f3f33e4ae90a578ec9e03b8197ed92c80a67c287abda2d3c3f8350d066b61229691d6a74c6286c5479bbbca7c39e99d008885397
DIST xpath-2.0.0.gem 18944 SHA256 9ca4a1cc88d9ab16c591468cce7b5d00ee06a8a76b841f8438970c7a44c86c12 SHA512 5d0375d795c755b88d4a16b7da9efe2bf234190066e38654360bbb0d837fdd481c946f055d95975d905330eef7e57d9b1eb4f1c5340d540db0fbd78fb58af690 WHIRLPOOL a745f438b9fe8471ec5975088aa97b2d1a6e587eefd93f248dec4fad2e17ea8acc1200fd88ee6517dcfc93e39bb684379d22e6aea52c8c421e75358aa644e8a6
+DIST xpath-2.1.0.gem 16896 SHA256 dc3f9c47c071b092d06bd17fc00e37a8d09e70b5eda645e375a04067aa1146c1 SHA512 50d80cac3fd65cbd211d3a87b8844a6607b14c841a1a5609e2370c3624daf719b937a61e526bf31aedee13346802d6bbb721d58bda2bef9c564c187b28bb90e2 WHIRLPOOL 753e00cb1f94f26138847e4ab833792764897dd8b57b8d014de68ea53e0c568b7752ea7c6726f78f12b6f2d2183ba10894c881aa44ed83398fb0470b32f35ead
diff --git a/dev-ruby/xpath/xpath-2.1.0.ebuild b/dev-ruby/xpath/xpath-2.1.0.ebuild
new file mode 100644
index 000000000000..d1b3556d3845
--- /dev/null
+++ b/dev-ruby/xpath/xpath-2.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0"
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="2"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/nokogiri )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|pry\)/d' spec/spec_helper.rb || die
+}