summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-11-05 06:50:00 +0100
committerHans de Graaff <graaff@gentoo.org>2017-11-05 06:50:00 +0100
commitc18b19717f2f46195577027d4f6f22a257cd157e (patch)
treee6bb2fa47af5509c0985490323c65a2b46e03a2d /dev-ruby
parentwww-apps/nanoc: cleanup (diff)
downloadgentoo-c18b19717f2f46195577027d4f6f22a257cd157e.tar.gz
gentoo-c18b19717f2f46195577027d4f6f22a257cd157e.tar.bz2
gentoo-c18b19717f2f46195577027d4f6f22a257cd157e.zip
dev-ruby/slow_enumerator_tools: initial import of 1.0.0
New dependency for www-apps/nanoc Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/slow_enumerator_tools/Manifest1
-rw-r--r--dev-ruby/slow_enumerator_tools/metadata.xml11
-rw-r--r--dev-ruby/slow_enumerator_tools/slow_enumerator_tools-1.0.0.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/slow_enumerator_tools/Manifest b/dev-ruby/slow_enumerator_tools/Manifest
new file mode 100644
index 000000000000..57e6c6a8ea88
--- /dev/null
+++ b/dev-ruby/slow_enumerator_tools/Manifest
@@ -0,0 +1 @@
+DIST slow_enumerator_tools-1.0.0.gem 11264 SHA256 2dedf34d23313fa7e6bad77fc16cd94ccc20f75a3b91b8c9b312b9c40dcb62ff SHA512 d557d913e74f2120e9a91350b5a04314285771b7c943087f943bc6a00dd421e27bd4941052c3cd74e20995ddbaa22ca8e9eb60a240fff54dd66b8e2b16d8c2ce WHIRLPOOL d07ac496fbfba9253b121005bdf0a75459287ec075e01f20bcf65b3f3c27c18099337d8e3fa45b81dcbb823aa48b8e180e14ecbd7247046cfce8d4d683e8ebe6
diff --git a/dev-ruby/slow_enumerator_tools/metadata.xml b/dev-ruby/slow_enumerator_tools/metadata.xml
new file mode 100644
index 000000000000..9ec605622c08
--- /dev/null
+++ b/dev-ruby/slow_enumerator_tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ddfreyne/slow_enumerator_tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/slow_enumerator_tools/slow_enumerator_tools-1.0.0.ebuild b/dev-ruby/slow_enumerator_tools/slow_enumerator_tools-1.0.0.ebuild
new file mode 100644
index 000000000000..9c7b8a34053a
--- /dev/null
+++ b/dev-ruby/slow_enumerator_tools/slow_enumerator_tools-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Transform Ruby enumerators that produce data slowly and unpredictably"
+HOMEPAGE="https://github.com/ddfreyne/slow_enumerator_tools/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/SimpleCov.formatter/ s:^:#:' \
+ -e '/fuubar/,/^end/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/Fuubar/d' .rspec || die
+}