summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-17 06:45:23 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-17 06:45:23 +0100
commitc5494192533520d0fbc84e1b34b0c48f7f65cbcd (patch)
tree10ebc775f09651c87c50e1845e9263de65387ec5 /dev-ruby
parentdev-ruby/bundler: add 2.2.10 (diff)
downloadgentoo-c5494192533520d0fbc84e1b34b0c48f7f65cbcd.tar.gz
gentoo-c5494192533520d0fbc84e1b34b0c48f7f65cbcd.tar.bz2
gentoo-c5494192533520d0fbc84e1b34b0c48f7f65cbcd.zip
dev-ruby/iobuffer: EAPI=7; fix extension install
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/iobuffer/iobuffer-1.1.2-r4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/iobuffer/iobuffer-1.1.2-r4.ebuild b/dev-ruby/iobuffer/iobuffer-1.1.2-r4.ebuild
new file mode 100644
index 000000000000..4e51dbd9bbfc
--- /dev/null
+++ b/dev-ruby/iobuffer/iobuffer-1.1.2-r4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC=iobuffer.gemspec
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit multilib ruby-fakegem
+
+GITHUB_USER="tarcieri"
+
+DESCRIPTION="IO::Buffer is a byte queue which is intended for non-blocking I/O applications"
+HOMEPAGE="https://github.com/tarcieri/iobuffer"
+SRC_URI="https://github.com/${GITHUB_USER}/iobuffer/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RUBY_S="${GITHUB_USER}-${PN}-*"
+
+all_ruby_prepare() {
+ rm .rspec lib/.gitignore Gemfile* || die
+}
+
+each_ruby_configure() {
+ each_fakegem_configure
+
+ sed -i -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" ext/Makefile || die
+}