summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-09-17 16:37:03 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-09-17 16:37:32 -0500
commitda2ce1057792e02b96a5446a357488aa554611b9 (patch)
treefe5052b4ef8a7c55444c78c88631b6a0ba328777 /dev-ruby
parentapp-admin/puppetserver: 7.4.0 bump (diff)
downloadgentoo-da2ce1057792e02b96a5446a357488aa554611b9.tar.gz
gentoo-da2ce1057792e02b96a5446a357488aa554611b9.tar.bz2
gentoo-da2ce1057792e02b96a5446a357488aa554611b9.zip
dev-ruby/puppetdb-termini: 7.6.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.6.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 975f3409c656..9b168c528b65 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_7.4.1-1stretch_all.deb 21552 BLAKE2B df93159a7dc9f6a6735f44531306a2b1c7a1bf9d8b88dbd4c9784367e949a83b0cb42dd8172880df9e7f4cbc1d3bcf9da570cdf2fa0437e525452d1f2468551d SHA512 4ffdf5e2019400dbaa5bb1fee22fd66fa430ab395a42d25cca2c61feaf68168b44eb1d29c0a9984a2cb669eff4ffadd9f9c64c6c19ea21bd3ceead392ad6d26b
DIST puppetdb-termini_7.5.0-1stretch_all.deb 21542 BLAKE2B 903a3290f3f10a199d53e5721fdac58aa771b2f9843037250be223df1f4db8328f4164c9f9756013bb5eba81d03fc13ef95b6806f64f6ecd70b7af8aa7336277 SHA512 d6179dbb4192ecfc1d082d32a978bb4d0c89f47db9c335ff70fc75bc81f41e3b0e78fa9fcd80ed3254ce57600e82f75ebefc217069dca8e0ea4014041878052b
+DIST puppetdb-termini_7.6.0-1stretch_all.deb 22010 BLAKE2B 535315b0b710fbd0aea5d4fb6964a38300d8da1c723a38153ac011bc326b75eaf9a8abc4804d60d20a078f8aabb01dc674112a0513f90b327dcd13d946cdd4a1 SHA512 cb3ebd4ff35b4b3be57c8a488e66faae1f44d130843cce95033baf3aac70a8519b0f775b3b41991cb5377cc78338141310662ba76a3985d19bcaacf2f7ea9038
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.6.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.6.0.ebuild
new file mode 100644
index 000000000000..a7cef96b4b13
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}