summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/guile-gnome-platform/guile-gnome-platform-2.16.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/guile-gnome-platform/guile-gnome-platform-2.16.1.ebuild')
-rw-r--r--dev-scheme/guile-gnome-platform/guile-gnome-platform-2.16.1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-scheme/guile-gnome-platform/guile-gnome-platform-2.16.1.ebuild b/dev-scheme/guile-gnome-platform/guile-gnome-platform-2.16.1.ebuild
new file mode 100644
index 000000000000..2a7eaab26754
--- /dev/null
+++ b/dev-scheme/guile-gnome-platform/guile-gnome-platform-2.16.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Guile Scheme code that wraps the GNOME developer platform"
+HOMEPAGE="http://www.gnu.org/software/guile-gnome"
+SRC_URI="http://ftp.gnu.org/pub/gnu/guile-gnome/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-scheme/guile-1.6.4
+ >=dev-libs/g-wrap-1.9.11
+ dev-scheme/guile-cairo
+ dev-libs/atk
+ gnome-base/libbonobo
+ gnome-base/orbit:2
+ >=gnome-base/gconf-2.18:2
+ >=dev-libs/glib-2.10:2
+ >=gnome-base/gnome-vfs-2.16:2
+ >=x11-libs/gtk+-2.10:2
+ >=gnome-base/libglade-2.6:2.0
+ >=gnome-base/libgnomecanvas-2.14
+ >=gnome-base/libgnomeui-2.16
+ >=x11-libs/pango-1.14
+ dev-scheme/guile-lib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+#needs guile with networking
+RESTRICT=test
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-conflicting-types.patch"
+ epatch "${FILESDIR}/${PV}-gcc45.patch"
+ epatch "${FILESDIR}/${PV}-glib-single-include.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-Werror
+}
+
+src_compile() {
+ emake -j1 guilegnomedir=/usr/share/guile/site \
+ guilegnomelibdir=/usr/$(get_libdir) || die "emake failed."
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" \
+ guilegnomedir=/usr/share/guile/site \
+ guilegnomelibdir=/usr/$(get_libdir) \
+ install || die "emake install failed."
+}