summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/kawa/kawa-1.14.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/kawa/kawa-1.14.ebuild')
-rw-r--r--dev-scheme/kawa/kawa-1.14.ebuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/dev-scheme/kawa/kawa-1.14.ebuild b/dev-scheme/kawa/kawa-1.14.ebuild
new file mode 100644
index 000000000000..18502abbd11f
--- /dev/null
+++ b/dev-scheme/kawa/kawa-1.14.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+JAVA_PKG_IUSE="source"
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="Kawa, the Java-based Scheme system & Language Framework"
+HOMEPAGE="http://www.gnu.org/software/kawa/"
+XQTS_Ver="1_0_3"
+SRC_URI="mirror://gnu/kawa/${P}.tar.gz
+ xqtests? ( http://www.w3.org/XML/Query/test-suite/XQTS_${XQTS_Ver}.zip )"
+
+LICENSE="MIT public-domain
+ jemacs? ( GPL-2 )
+ krl? ( GPL-2 )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="+awt echo2 +frontend jemacs krl +sax servlets +swing swt +xml xqtests"
+
+CDEPEND="( >=virtual/jdk-1.6 )
+ frontend? ( sys-libs/readline:0 )
+ sax? ( dev-java/sax:0 )
+ echo2? ( dev-java/echo2 )
+ swt? ( dev-java/swt:3.5 )
+ servlets? ( java-virtuals/servlet-api:3.0 )"
+DEPEND="${CDEPEND}
+ xqtests? ( app-arch/unzip:0 )"
+RDEPEND="${CDEPEND}"
+
+xtestsuite="XQTS_${XQTS_Ver}"
+
+src_unpack () {
+ unpack kawa-${PV}.tar.gz || die
+ if use xqtests; then
+ mkdir "${WORKDIR}/${xtestsuite}" || die
+ cd "${WORKDIR}/${xtestsuite}" || die
+ unpack ${xtestsuite}.Zip || die
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_configure() {
+ # speeds up one-shot ebuilds.
+ myconf="--disable-dependency-tracking"
+ if use jemacs && ! use swing; then
+ echo
+ einfo "Although the swing USE flag is disabled you chose to enable jemacs,"
+ einfo "so swing is enabled anyway."
+ echo
+ myconf="${myconf} --with-swing"
+ else
+ myconf="${myconf} $(use_with swing)"
+ fi
+ if use xqtests; then
+ myconf="${myconf} $(use_with xqtests XQTS=${WORKDIR}/${xtestsuite})"
+ fi
+ if use servlets; then
+ myconf="${myconf} --with-servlet=$(java-pkg_getjar servletapi-2.4 servlet-api.jar)"
+ fi
+ if use swt; then
+ myconf="${myconf} --with-swt=$(java-pkg_getjar swt-3.5 swt.jar)"
+ fi
+
+ econf ${myconf} $(use_enable frontend kawa-frontend) \
+ $(use_enable xml) \
+ $(use_enable krl brl) \
+ $(use_enable echo2) \
+ $(use_enable jemacs) \
+ $(use_with awt) \
+ $(use_with sax sax2) \
+ --with-java-source=$(java-pkg_get-source) || die "econf failed."
+}
+
+src_compile() {
+ emake -j1 || die "emake failed."
+}
+
+src_install () {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ rm -rv "${D}"/usr/share/java/ || die "rm -rv failed"
+
+ java-pkg_newjar kawa-${PV}.jar || die
+
+ java-pkg_dolauncher "kawa" --main kawa.repl || die "dolauncher failed"
+ java-pkg_dolauncher "qexo" --main kawa.repl --pkg_args \
+ "--xquery" || die "dolauncher qexo failed"
+ if use servlets; then
+ java-pkg_dolauncher "kawa-cgi-servlet" --main \
+ gnu.kawa.servlet.CGIServletWrapper || die
+ fi
+ if use jemacs; then
+ java-pkg_dolauncher "jemacs" --main \
+ gnu.jemacs.lang.ELisp || die
+ fi
+
+ use source && java-pkg_dosrc kawa/* gnu/*
+
+ dodoc ChangeLog TODO README NEWS || die
+ doinfo doc/kawa.info* || die
+ cp doc/kawa.man doc/kawa.2 || die
+ cp doc/qexo.man doc/qexo.2 || die
+ doman doc/*.2 || die
+}