summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-11-08 12:39:11 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-11-08 12:39:42 +0100
commit859d9140a96b785ab1ffa027b94b55864ea18070 (patch)
treead30acec6fbd7fcead74c26d141456c2a542a70f /dev-scheme/mit-scheme
parentapp-emacs/editorconfig-emacs: bump to 0.9.1 (diff)
downloadgentoo-859d9140a96b785ab1ffa027b94b55864ea18070.tar.gz
gentoo-859d9140a96b785ab1ffa027b94b55864ea18070.tar.bz2
gentoo-859d9140a96b785ab1ffa027b94b55864ea18070.zip
dev-scheme/mit-scheme: build microcode first
Closes: https://bugs.gentoo.org/879901 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme/mit-scheme')
-rw-r--r--dev-scheme/mit-scheme/mit-scheme-11.2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-scheme/mit-scheme/mit-scheme-11.2.ebuild b/dev-scheme/mit-scheme/mit-scheme-11.2.ebuild
index b2cbd7f95756..3983d9d42651 100644
--- a/dev-scheme/mit-scheme/mit-scheme-11.2.ebuild
+++ b/dev-scheme/mit-scheme/mit-scheme-11.2.ebuild
@@ -41,6 +41,9 @@ src_configure() {
}
src_compile() {
+ # Compile the "microcode" first, bug #879901
+ emake -C microcode
+
# Fails with multiple make-jobs, at least it compiles relatively fast.
emake -j1
}
@@ -53,7 +56,7 @@ src_compile() {
# runtime/test-flonum.com
src_test() {
- FAST=y emake check
+ FAST=y emake check -j1
}
src_install() {