summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-02 23:13:02 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-02 23:15:31 +0200
commitae9927335753a768f7f9c70558d6895d924d7a24 (patch)
tree2d339f2926642d7bb0e45f9adb3e1e80abf98104 /dev-scheme/stklos/stklos-1.10-r1.ebuild
parentsys-cluster/ceph: Revision bump to 10.2.9, pull in fixes from upstream (diff)
downloadgentoo-ae9927335753a768f7f9c70558d6895d924d7a24.tar.gz
gentoo-ae9927335753a768f7f9c70558d6895d924d7a24.tar.bz2
gentoo-ae9927335753a768f7f9c70558d6895d924d7a24.zip
dev-scheme/stklos: eapi bump to 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-scheme/stklos/stklos-1.10-r1.ebuild')
-rw-r--r--dev-scheme/stklos/stklos-1.10-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-scheme/stklos/stklos-1.10-r1.ebuild b/dev-scheme/stklos/stklos-1.10-r1.ebuild
new file mode 100644
index 000000000000..16e52f98762b
--- /dev/null
+++ b/dev-scheme/stklos/stklos-1.10-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="fast and light Scheme implementation"
+HOMEPAGE="http://www.stklos.net"
+SRC_URI="http://www.stklos.net/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+DEPEND="dev-libs/gmp:= dev-libs/libpcre virtual/libffi dev-libs/boehm-gc[threads?]"
+RDEPEND="${DEPEND}"
+
+#parallel build failure reported upstream
+MAKEOPTS=-j1
+
+src_prepare() {
+ # kill bundled libs
+ rm -rf "${S}"/{ffi,gc,gmp,pcre} || die
+ default
+}
+
+src_configure() {
+ econf --enable-threads=$(if use threads; then echo pthreads; else echo none; fi) \
+ --without-gmp-light --without-provided-gc \
+ --without-provided-regexp --without-provided-ffi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS PACKAGES-USED PORTING-NOTES README SUPPORTED-SRFIS
+}