summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/tinyscheme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/tinyscheme')
-rw-r--r--dev-scheme/tinyscheme/Manifest1
-rw-r--r--dev-scheme/tinyscheme/files/tinyscheme-1.41-makefile.patch50
-rw-r--r--dev-scheme/tinyscheme/metadata.xml11
-rw-r--r--dev-scheme/tinyscheme/tinyscheme-1.41.ebuild63
4 files changed, 125 insertions, 0 deletions
diff --git a/dev-scheme/tinyscheme/Manifest b/dev-scheme/tinyscheme/Manifest
new file mode 100644
index 000000000000..de19d83e7be0
--- /dev/null
+++ b/dev-scheme/tinyscheme/Manifest
@@ -0,0 +1 @@
+DIST tinyscheme-1.41.tar.gz 61761 SHA256 eac0103494c755192b9e8f10454d9f98f2bbd4d352e046f7b253439a3f991999 SHA512 a9c1c9cd7a11bf31e0f8ac813ebd6e731cb56b9526fd14d343d7f8c479a8e1b561b744b3f522512adc023cacd1acbf52aa18bf5d8db68f767971660305b79b0f WHIRLPOOL 4df1f6f80a03c1dae73cd0e39fead9d454c41be536c4a9ec63da80ab31e5712bae0f8a2e8a58154edcc4d595129a11399f65e59fe9f0524b7669912ce16825cf
diff --git a/dev-scheme/tinyscheme/files/tinyscheme-1.41-makefile.patch b/dev-scheme/tinyscheme/files/tinyscheme-1.41-makefile.patch
new file mode 100644
index 000000000000..69fccb5e537a
--- /dev/null
+++ b/dev-scheme/tinyscheme/files/tinyscheme-1.41-makefile.patch
@@ -0,0 +1,50 @@
+diff -ru a/makefile b/makefile
+--- a/makefile 2013-04-14 20:08:33.000000000 +0000
++++ b/makefile 2013-12-11 11:59:58.688782748 +0000
+@@ -18,8 +18,7 @@
+ #AR= echo
+
+ # Unix, generally
+-CC = gcc -fpic -pedantic
+-DEBUG=-g -Wall -Wno-char-subscripts -O
++#CC = $(CC)
+ Osuf=o
+ SOsuf=so
+ LIBsuf=a
+@@ -27,12 +26,11 @@
+ LIBPREFIX=lib
+ OUT = -o $@
+ RM= -rm -f
+-AR= ar crs
++#AR= $(AR)
++ARFLAGS = crs
+
+ # Linux
+-LD = gcc
+-LDFLAGS = -shared
+-DEBUG=-g -Wno-char-subscripts -O
++#LD = $(CC)
+ SYS_LIBS= -ldl -lm
+ PLATFORM_FEATURES= -DSUN_DL=1
+
+@@ -71,16 +69,16 @@
+ all: $(LIBTARGET) $(STATICLIBTARGET) scheme$(EXE_EXT)
+
+ %.$(Osuf): %.c
+- $(CC) -I. -c $(DEBUG) $(FEATURES) $(DL_FLAGS) $<
++ $(CC) -fpic $(CFLAGS) -I. -c $(FEATURES) $(DL_FLAGS) $<
+
+ $(LIBTARGET): $(OBJS)
+- $(LD) $(LDFLAGS) $(OUT) $(OBJS) $(SYS_LIBS)
++ $(CC) -shared $(LDFLAGS) -Wl,-soname=$@ -o $@ $(OUT) $(OBJS) $(SYS_LIBS)
+
+ scheme$(EXE_EXT): $(OBJS)
+- $(CC) -o $@ $(DEBUG) $(OBJS) $(SYS_LIBS)
++ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(SYS_LIBS)
+
+ $(STATICLIBTARGET): $(OBJS)
+- $(AR) $@ $(OBJS)
++ $(AR) $(ARFLAGS) $@ $(OBJS)
+
+ $(OBJS): scheme.h scheme-private.h opdefines.h
+ dynload.$(Osuf): dynload.h
diff --git a/dev-scheme/tinyscheme/metadata.xml b/dev-scheme/tinyscheme/metadata.xml
new file mode 100644
index 000000000000..b60f12cff3b7
--- /dev/null
+++ b/dev-scheme/tinyscheme/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>scheme</herd>
+ <longdescription lang="en">
+TinyScheme is a lightweight Scheme interpreter that implements as large a subset of R5RS as was possible without getting very large and complicated. It is meant to be used as an embedded scripting interpreter for other programs. As such, it does not offer IDEs or extensive toolkits although it does sport a small top-level loop, included conditionally. A lot of functionality in TinyScheme is included conditionally, to allow developers freedom in balancing features and footprint.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tinyscheme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-scheme/tinyscheme/tinyscheme-1.41.ebuild b/dev-scheme/tinyscheme/tinyscheme-1.41.ebuild
new file mode 100644
index 000000000000..ae4d9719956a
--- /dev/null
+++ b/dev-scheme/tinyscheme/tinyscheme-1.41.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit flag-o-matic multilib
+
+DESCRIPTION="Lightweight scheme interpreter"
+HOMEPAGE="http://tinyscheme.sourceforge.net"
+SRC_URI="mirror://sourceforge/tinyscheme/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+#KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 ppc x86"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ append-flags -DOSX
+ sed -i \
+ -e 's/SOsuf=so/SOsuf=dylib/' \
+ -e "s|-Wl,-soname=|-Wl,-install_name=${EPREFIX}/usr/lib/|" \
+ makefile || die
+ fi
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"\
+ AR=$(tc-getAR) CC=$(tc-getCC)
+}
+
+src_install() {
+
+ local tslib=libtinyscheme$(get_libname)
+ local tslibx=libtinyscheme$(get_libname ${PV})
+
+ newbin scheme ${PN}
+
+ newlib.so ${tslib} ${tslibx}
+ dosym ${tslibx} /usr/$(get_libdir)/${tslib}
+ dodoc Manual.txt || die "dodoc failed"
+
+ if use static-libs; then
+ dolib.a libtinyscheme.a
+ fi
+
+ # Bug 328967: dev-scheme/tinyscheme-1.39-r1 doesn't install header file
+ insinto /usr/include/
+ newins scheme.h tinyscheme.h
+
+ local INIT_DIR=/usr/share/${PN}/
+ insinto ${INIT_DIR}
+ doins init.scm
+ dodir /etc/env.d/ && echo "TINYSCHEMEINIT=\"${EPREFIX}${INIT_DIR}init.scm\"" > "${ED}"/etc/env.d/50tinyscheme
+}