summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-26 09:54:08 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-26 09:54:41 +0100
commit0360ae9d079b2ae15731bdb268f2c153517222ef (patch)
tree9715f5e56d53b2dc47bc8ca90b6a1f5a35e794c3 /dev-scheme
parentmedia-gfx/fotoxx: x86 stable wrt bug #827113 (diff)
downloadgentoo-0360ae9d079b2ae15731bdb268f2c153517222ef.tar.gz
gentoo-0360ae9d079b2ae15731bdb268f2c153517222ef.tar.bz2
gentoo-0360ae9d079b2ae15731bdb268f2c153517222ef.zip
dev-scheme/guile-colorized: new package; add version 0.1_p20191205 and live
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile-colorized/Manifest1
-rw-r--r--dev-scheme/guile-colorized/guile-colorized-0.1_p20191205.ebuild39
-rw-r--r--dev-scheme/guile-colorized/guile-colorized-9999.ebuild39
-rw-r--r--dev-scheme/guile-colorized/metadata.xml13
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-scheme/guile-colorized/Manifest b/dev-scheme/guile-colorized/Manifest
new file mode 100644
index 000000000000..6f434c2fa894
--- /dev/null
+++ b/dev-scheme/guile-colorized/Manifest
@@ -0,0 +1 @@
+DIST guile-colorized-0.1_p20191205.tar.bz2 15496 BLAKE2B a85fc44c3b6b8433362197a4f1da216ea99793673ee4592e6ea32178d2952d0f43f5a4e79304185d0c67b6dee668bf52d53970df97954a37650cd8b7770e7abd SHA512 4cd9833c70debf0086ba69252e1fb8b9fc33707ec1f3bb6dfb144d5a35db6f38e3af585cbc889936c8ebb38dea0f8808f483bd51ed1722c9b9df857d31a7cec7
diff --git a/dev-scheme/guile-colorized/guile-colorized-0.1_p20191205.ebuild b/dev-scheme/guile-colorized/guile-colorized-0.1_p20191205.ebuild
new file mode 100644
index 000000000000..65a9e38bf9be
--- /dev/null
+++ b/dev-scheme/guile-colorized/guile-colorized-0.1_p20191205.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Colorized REPL for GNU Guile"
+HOMEPAGE="https://gitlab.com/NalaGinrut/guile-colorized/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/NalaGinrut/${PN}.git"
+else
+ # Latest release (before this commit from 2019) was in 2015
+ COMMIT_SHA="1625a79f0e31849ebd537e2a58793fb45678c58f"
+ SRC_URI="https://gitlab.com/NalaGinrut/${PN}/-/archive/${COMMIT_SHA}.tar.bz2 -> ${P}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${COMMIT_SHA}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND=">=dev-scheme/guile-2.0.9:="
+DEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}
+
+src_install() {
+ einstalldocs
+
+ local loadpath=$(guile -c '(display (string-append (car %load-path) "/ice-9"))')
+ mkdir -p "${D}${loadpath}"
+ emake TARGET="${D}${loadpath}" install
+}
diff --git a/dev-scheme/guile-colorized/guile-colorized-9999.ebuild b/dev-scheme/guile-colorized/guile-colorized-9999.ebuild
new file mode 100644
index 000000000000..65a9e38bf9be
--- /dev/null
+++ b/dev-scheme/guile-colorized/guile-colorized-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Colorized REPL for GNU Guile"
+HOMEPAGE="https://gitlab.com/NalaGinrut/guile-colorized/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/NalaGinrut/${PN}.git"
+else
+ # Latest release (before this commit from 2019) was in 2015
+ COMMIT_SHA="1625a79f0e31849ebd537e2a58793fb45678c58f"
+ SRC_URI="https://gitlab.com/NalaGinrut/${PN}/-/archive/${COMMIT_SHA}.tar.bz2 -> ${P}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${COMMIT_SHA}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND=">=dev-scheme/guile-2.0.9:="
+DEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}
+
+src_install() {
+ einstalldocs
+
+ local loadpath=$(guile -c '(display (string-append (car %load-path) "/ice-9"))')
+ mkdir -p "${D}${loadpath}"
+ emake TARGET="${D}${loadpath}" install
+}
diff --git a/dev-scheme/guile-colorized/metadata.xml b/dev-scheme/guile-colorized/metadata.xml
new file mode 100644
index 000000000000..c1ef4deb0fd4
--- /dev/null
+++ b/dev-scheme/guile-colorized/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>scheme@gentoo.org</email>
+ <name>Gentoo Scheme Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/NalaGinrut/guile-colorized/-/issues</bugs-to>
+ <remote-id type="gitlab">NalaGinrut/guile-colorized</remote-id>
+ </upstream>
+</pkgmetadata>