summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-11-27 15:38:15 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-11-27 15:39:06 +0900
commite645ec1b64380686ddcd772b5fdcb29cb2f7055c (patch)
tree692826c9ca109ef476104f4f5a490bdcbcc8a332 /dev-scheme
parentdev-scheme/stklos: fix installation paths (diff)
downloadgentoo-e645ec1b64380686ddcd772b5fdcb29cb2f7055c.tar.gz
gentoo-e645ec1b64380686ddcd772b5fdcb29cb2f7055c.tar.bz2
gentoo-e645ec1b64380686ddcd772b5fdcb29cb2f7055c.zip
dev-scheme/stklos: new upstream release
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/stklos/Manifest1
-rw-r--r--dev-scheme/stklos/files/stklos-1.70-gentoo.patch56
-rw-r--r--dev-scheme/stklos/stklos-1.70.ebuild53
3 files changed, 110 insertions, 0 deletions
diff --git a/dev-scheme/stklos/Manifest b/dev-scheme/stklos/Manifest
index 4074e491edc0..c40762c851b0 100644
--- a/dev-scheme/stklos/Manifest
+++ b/dev-scheme/stklos/Manifest
@@ -1 +1,2 @@
DIST stklos-1.10.tar.gz 6097807 BLAKE2B bfb957c54626d29cc1ecba553a0b982022b1ed0b89f333d763937e8c5f84b5c6b80ebc1e6531d968f4b33d72427a4f9957c010932308672907e105d37828ee50 SHA512 64877dec82b4c19bcaea95f6c60a4b9dff19c11bf11792fa5204d0ca3bb6f6962cc9250b35dcd5f01015e430b9a027add4f40c6a7169858893cab3e8c8df0bbb
+DIST stklos-1.70.tar.gz 8767615 BLAKE2B 7cae5b5d0c9b2d9dcccc47e78e70a562f2d1751de068668777441d29ee15be7f3c5c285b8297e367311cd8c9695c9a2d083ad7ea1d9c21c838cf1d819f7cb82c SHA512 64da09171b191688f750f10c29f10cd7393f326555d4324344faeac63547a2548407490e44a50f0afa348487bd9cc5106f3c344cab6935f3a3516b3c064a596f
diff --git a/dev-scheme/stklos/files/stklos-1.70-gentoo.patch b/dev-scheme/stklos/files/stklos-1.70-gentoo.patch
new file mode 100644
index 000000000000..954b15a617b2
--- /dev/null
+++ b/dev-scheme/stklos/files/stklos-1.70-gentoo.patch
@@ -0,0 +1,56 @@
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -21,7 +21,6 @@
+ # Creation date: 11-Apr-2000 10:30 (eg)
+ # Last file update: 1-Jun-2021 19:13 (eg)
+
+-mandir = $(prefix)/share/man
+ man_MANS = stklos.1 stklos-config.1 stklos-compile.1 stklos-genlex.1 \
+ stklos-pkg.1 stklos-script.1
+ EXTRA_DIST = $(man_MANS)
+@@ -33,12 +32,10 @@
+ schemedir = $(prefix)/share/@PACKAGE@/@VERSION@
+ scheme_DATA = DOCDB
+
+-doclocation = $(prefix)/share/doc/@PACKAGE@-@VERSION@
+-
+-docpdfdir = $(doclocation)/pdf
++docpdfdir = $(pdfdir)
+ docpdf_DATA = pdf/stklos-ref.pdf
+
+-dochtmldir = $(doclocation)/html
++dochtmldir = $(htmldir)
+ dochtml_DATA= html/index.html \
+ html/stklos-ref.html \
+ html/stklos-ref-1.html \
+@@ -59,7 +56,7 @@
+ html/stklos-ref-16.html \
+ html/doc-style.css
+
+-docimgdir = $(doclocation)/html/images
++docimgdir = $(htmldir)/images
+ docimg_DATA = html/images/hierarchy.jpg
+
+
+--- a/lib/Lalr.d/Makefile.am
++++ b/lib/Lalr.d/Makefile.am
+@@ -34,7 +34,7 @@
+ all: lalr.ostk calc
+
+ install-sources: install
+- mkdir -p $(schemedir)
++ mkdir -p $(DESTDIR)/$(schemedir)
+ cp lalr.stk $(DESTDIR)/$(schemedir)
+
+ uninstall-hook:
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -123,8 +123,6 @@
+
+
+ install-exec-hook:
+- @echo "STRIP command: $$STRIP"
+- if test "X$$STRIP" != "Xno" ;then $(STRIP) $(DESTDIR)/$(bindir)/stklos; fi;
+ mv $(DESTDIR)/$(bindir)/stklos $(DESTDIR)/$(bindir)/stklos-@VERSION@
+ ln -s stklos-@VERSION@ $(DESTDIR)/$(bindir)/stklos
+
diff --git a/dev-scheme/stklos/stklos-1.70.ebuild b/dev-scheme/stklos/stklos-1.70.ebuild
new file mode 100644
index 000000000000..b3cc1f2b0cc6
--- /dev/null
+++ b/dev-scheme/stklos/stklos-1.70.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools
+
+DESCRIPTION="fast and light Scheme implementation"
+HOMEPAGE="https://www.stklos.net/"
+SRC_URI="https://www.${PN}.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+
+RDEPEND="dev-libs/boehm-gc[threads?]
+ dev-libs/gmp:=
+ dev-libs/libffi:=
+ dev-libs/libpcre"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+DOCS=( AUTHORS ChangeLog {HACKING,NEWS}.md PACKAGES-USED {PORTING-NOTES,README}.md SUPPORTED-SRFIS )
+
+src_prepare() {
+ use threads || rm -f tests/srfis/216.stk
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-threads=$(usex threads pthreads none) \
+ --without-gmp-light \
+ --without-provided-ffi \
+ --without-provided-gc \
+ --without-provided-regexp
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ einstalldocs
+}