summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-05-09 09:23:51 -0700
committerMaciej Barć <xgqt@gentoo.org>2022-05-09 18:38:22 +0200
commite9b4a8bfad4ca23a97239ff8d1bad011da038fab (patch)
treea98d53101466de4cc314a01400496a305dbbcf33 /dev-scheme
parentsci-visualization/scidavis: drop 2.7-r1, 2.8 (diff)
downloadgentoo-e9b4a8bfad4ca23a97239ff8d1bad011da038fab.tar.gz
gentoo-e9b4a8bfad4ca23a97239ff8d1bad011da038fab.tar.bz2
gentoo-e9b4a8bfad4ca23a97239ff8d1bad011da038fab.zip
dev-scheme/guile-ncurses: Fix build with slibtool
On Gentoo both -lncurses and -ltinfow are needed where the build misses the latter. Additionally GNU libtool silently ignores -no-undefined while slibtool does not. Bug: https://bugs.gentoo.org/843416 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/25404 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile-ncurses/files/guile-ncurses-3.0-slibtool.patch38
-rw-r--r--dev-scheme/guile-ncurses/guile-ncurses-3.0.ebuild4
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-scheme/guile-ncurses/files/guile-ncurses-3.0-slibtool.patch b/dev-scheme/guile-ncurses/files/guile-ncurses-3.0-slibtool.patch
new file mode 100644
index 000000000000..5c102fca6011
--- /dev/null
+++ b/dev-scheme/guile-ncurses/files/guile-ncurses-3.0-slibtool.patch
@@ -0,0 +1,38 @@
+commit 8c8327c8518508380bd68f52db19432b776833e5
+Author: orbea <orbea@riseup.net>
+Date: Mon May 9 09:06:04 2022 -0700
+
+ build: Link with -ltinfow/-ltinfow to fix undefined references
+
+diff --git a/configure.ac b/configure.ac
+index f194166..954d9b2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -200,6 +200,13 @@ AS_IF([test "$with_ncursesw" = check],
+ with_ncursesw=yes],
+ [AC_MSG_FAILURE([--with-ncursesw was given, but, test for ncursesw failed])])])
+
++AS_IF([test "$with_ncursesw" = yes],
++ [AC_SEARCH_LIBS([LINES], [tinfow],
++ [AC_DEFINE([HAVE_TINFOW],
++ [1],
++ [Define if you have libtinfow])],
++ [AC_MSG_FAILURE([--with-ncursesw was given, but, test for tinfow failed])])])
++
+ AS_IF([test "$with_ncursesw" = no],
+ [AC_SEARCH_LIBS([initscr], [ncurses],
+ [AC_DEFINE([HAVE_NCURSES],
+@@ -207,6 +214,13 @@ AS_IF([test "$with_ncursesw" = no],
+ [Define if you have libncurses])],
+ [AC_MSG_FAILURE([the ncurses library was not found])])])
+
++AS_IF([test "$with_ncursesw" = no],
++ [AC_SEARCH_LIBS([LINES], [tinfo],
++ [AC_DEFINE([HAVE_TINFO],
++ [1],
++ [Define if you have libntinfo])],
++ [AC_MSG_FAILURE([the tinfo library was not found])])])
++
+ AM_CONDITIONAL([WIDE], [test "$with_ncursesw" = yes])
+
+ AC_MSG_NOTICE([checking for term.h])
diff --git a/dev-scheme/guile-ncurses/guile-ncurses-3.0.ebuild b/dev-scheme/guile-ncurses/guile-ncurses-3.0.ebuild
index 361ce458158d..9c058b78c2dc 100644
--- a/dev-scheme/guile-ncurses/guile-ncurses-3.0.ebuild
+++ b/dev-scheme/guile-ncurses/guile-ncurses-3.0.ebuild
@@ -23,6 +23,10 @@ BDEPEND="sys-apps/texinfo"
# It's a portage's false positive. bug #677600
QA_PREBUILT='*[.]go'
+PATCHES=(
+ "${FILESDIR}/${P}-slibtool.patch" # 843416
+)
+
src_prepare() {
default