summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-05-15 23:34:59 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-05-15 23:34:59 +0200
commita3f346c96bb08dcd330f5bcd6a027e430ffafac2 (patch)
tree64b97f9b6408796cf1a3b0d3556bdda987e3e48a /dev-tcltk/expect
parentdev-util/rats: Remove old (diff)
downloadgentoo-a3f346c96bb08dcd330f5bcd6a027e430ffafac2.tar.gz
gentoo-a3f346c96bb08dcd330f5bcd6a027e430ffafac2.tar.bz2
gentoo-a3f346c96bb08dcd330f5bcd6a027e430ffafac2.zip
dev-tcltk/expect: Remove old
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-tcltk/expect')
-rw-r--r--dev-tcltk/expect/Manifest1
-rw-r--r--dev-tcltk/expect/expect-5.44.1.15.ebuild96
2 files changed, 0 insertions, 97 deletions
diff --git a/dev-tcltk/expect/Manifest b/dev-tcltk/expect/Manifest
index 840a8748c16c..6825d4065498 100644
--- a/dev-tcltk/expect/Manifest
+++ b/dev-tcltk/expect/Manifest
@@ -1,2 +1 @@
-DIST expect-5.44.1.15.tar.bz2 547655 SHA256 c8565b869d67389995684b60553685168dd40135aa50022bd759f2d5e757d6f1 SHA512 ef7b90dcad733d8c02264d9ff2ad1b018bb50923f78fd16181e9cae2bcdd49dba723da1ef8bada0a3b570399760f198390e7e51f5f90a34f80f845c2244ea336 WHIRLPOOL cf464abf7f27fc7dd33dd9d98bb7dfc27cfde9cc90bf74098fcce17a7a4d78c46db49b72bcd0c7bd7a45580ec37cf5f3b57971bacb4302586c1520413ce5dfd0
DIST expect5.45.tar.gz 628808 SHA256 b28dca90428a3b30e650525cdc16255d76bb6ccd65d448be53e620d95d5cc040 SHA512 be991c68241e607b3a689eae7e7966056dbfb577e857331d54a4911bd178c1816425217603b43918ad1b6d2e966271a0f01e79d7028a22e223562d59d10c8c51 WHIRLPOOL e28a5019036d20260f76b13cbd47d2e56661b0107592ead296118c12ed28157a1300a091730820e088d2fa6f86396e7244e844c7bc2e942fc6cf995e4194f10f
diff --git a/dev-tcltk/expect/expect-5.44.1.15.ebuild b/dev-tcltk/expect/expect-5.44.1.15.ebuild
deleted file mode 100644
index 79531c27bd1d..000000000000
--- a/dev-tcltk/expect/expect-5.44.1.15.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="3"
-
-inherit autotools eutils
-
-DESCRIPTION="tool for automating interactive applications"
-HOMEPAGE="http://expect.nist.gov/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="debug doc threads X"
-
-# We need dejagnu for src_test, but dejagnu needs expect
-# to compile/run, so we cant add dejagnu to DEPEND :/
-DEPEND=">=dev-lang/tcl-8.2:0[threads?]
- X? ( >=dev-lang/tk-8.2:0[threads?] )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expect{,k}.man || die
- # stops any example scripts being installed by default
- sed -i \
- -e 's/^SCRIPT_LIST/_&/' \
- -e 's/^SCRIPTS/_&/' \
- -e 's/^SCRIPTS_MANPAGES = /_&/' \
- Makefile.in
-
- epatch "${FILESDIR}"/${P}-gfbsd.patch
- epatch "${FILESDIR}"/${P}-ldflags.patch
- epatch "${FILESDIR}"/${P}_with-tk-no.patch
- epatch "${FILESDIR}"/${P}-headers.patch #337943
- epatch "${FILESDIR}"/${P}-expectk.patch
- sed -i 's:ifdef HAVE_SYS_WAIT_H:ifndef NO_SYS_WAIT_H:' *.c
-
- eautoconf
-}
-
-src_configure() {
- local myconf
- local tclv
- local tkv
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER ${EPREFIX}/usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- #tkv isn't really needed, included for symmetry and the future
- #tkv=$(grep TK_VER ${EPREFIX}/usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
- myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${EPREFIX}/usr/$(get_libdir)/tcl${tclv}/include/generic --with-tk=yes"
-
- if use X ; then
- #--with-x is enabled by default
- #configure needs to find the file tkConfig.sh and tk.h
- #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir) --with-tkinclude=${EPREFIX}/usr/include"
- else
- #configure knows that tk depends on X so just disable X
- myconf="$myconf --with-tk=no"
- fi
-
- econf \
- $myconf \
- --enable-shared \
- $(use_enable threads) \
- $(use_enable amd64 64bit) \
- $(use_enable debug symbols)
-}
-
-src_test() {
- # we need dejagnu to do tests ... but dejagnu needs
- # expect ... so don't do tests unless we have dejagnu
- type -p runtest || return 0
- emake test || die "emake test failed"
-}
-
-expect_make_var() {
- touch pkgIndex.tcl-hand
- printf 'all:;echo $('$1')\ninclude Makefile' | emake --no-print-directory -s -f -
- rm -f pkgIndex.tcl-hand
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc ChangeLog FAQ HISTORY NEWS README
-
- # install examples if 'doc' is set
- if use doc ; then
- insinto /usr/share/doc/${PF}/examples
- doins $(printf 'example/%s ' $(expect_make_var SCRIPTS)) || die
- docinto examples
- dodoc example/README $(printf 'example/%s.man ' $(expect_make_var _SCRIPTS_MANPAGES)) || die
- fi
-}