summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tkcon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tkcon')
-rw-r--r--dev-tcltk/tkcon/Manifest1
-rw-r--r--dev-tcltk/tkcon/metadata.xml15
-rw-r--r--dev-tcltk/tkcon/tkcon-2.5.ebuild30
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-tcltk/tkcon/Manifest b/dev-tcltk/tkcon/Manifest
new file mode 100644
index 000000000000..c6fc4d252056
--- /dev/null
+++ b/dev-tcltk/tkcon/Manifest
@@ -0,0 +1 @@
+DIST tkcon-2.5.tar.gz 139834 SHA256 3ff3eb7198b060d2c3bdc195c1f7d8532e63742447179fbb6091a3886bab42a9 SHA512 f53d21dbf281112b761970b05aa643d598819789644445a0e01f6eddcf98709c4b7ef635bc69ec40fc14b5c78397b240b86d8b6ed63aac48f656242c19fd7851 WHIRLPOOL 0d13bb208292ab9a9782eaf0b4d92848f866c36e178556671563ebecc4a48ebb3c766fb09b94e24932cbd293f5ff098c50fcd99bcf7223e7ba4efb17f2e59e10
diff --git a/dev-tcltk/tkcon/metadata.xml b/dev-tcltk/tkcon/metadata.xml
new file mode 100644
index 000000000000..021d026a88a7
--- /dev/null
+++ b/dev-tcltk/tkcon/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <longdescription lang="en">
+ tkcon is a replacement for the standard console that comes with
+ Tk. The console itself provides more features than the standard
+ console. It is meant primarily to aid one when working with the
+ little details inside tcl and tk, giving UNIX users the GUI console
+ provided by default in the Mac and Windows Tk.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tkcon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tcltk/tkcon/tkcon-2.5.ebuild b/dev-tcltk/tkcon/tkcon-2.5.ebuild
new file mode 100644
index 000000000000..b3add8dea439
--- /dev/null
+++ b/dev-tcltk/tkcon/tkcon-2.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib
+
+DESCRIPTION="Tk GUI console"
+HOMEPAGE="http://tkcon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="dev-lang/tk"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local tclver="$(echo 'puts $tcl_version' | tclsh)"
+ local instdir=/usr/$(get_libdir)/tcl${tclver}/${PN}2.5
+ dodir ${instdir}
+ cp -pP pkgIndex.tcl tkcon.tcl "${D}"${instdir} || die
+ dodir /usr/bin
+ dosym ${instdir}/tkcon.tcl /usr/bin/tkcon
+ dodoc README.txt
+ if use doc; then
+ dohtml doc/*
+ fi
+}