summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tkpng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tkpng')
-rw-r--r--dev-tcltk/tkpng/Manifest1
-rw-r--r--dev-tcltk/tkpng/metadata.xml11
-rw-r--r--dev-tcltk/tkpng/tkpng-0.9.ebuild34
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-tcltk/tkpng/Manifest b/dev-tcltk/tkpng/Manifest
new file mode 100644
index 000000000000..97743a7ba39c
--- /dev/null
+++ b/dev-tcltk/tkpng/Manifest
@@ -0,0 +1 @@
+DIST tkpng0.9.tgz 127804 SHA256 92f361d4f43c3a0638f85f87af6cef30c63a1896fa59a9220bcfab4852ab10fb SHA512 7f832ec19b53ba0f98d3db24d7b7106ae9bb6983d46ee33c46e90a1b152646f2a99ea417c9c6f9bed1f2859ef509510b531d26b3bb81f20d4e291ea1092896fb WHIRLPOOL 30243c54ccefb07d430963a8afdc4852134d8f735cb7feeb6b690587174e33be6bae61e3405a1b7d1d4a7019a1db019e54f4617e12e8350d3a4547009ea5f19e
diff --git a/dev-tcltk/tkpng/metadata.xml b/dev-tcltk/tkpng/metadata.xml
new file mode 100644
index 000000000000..59b019a72d38
--- /dev/null
+++ b/dev-tcltk/tkpng/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">tkpng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tcltk/tkpng/tkpng-0.9.ebuild b/dev-tcltk/tkpng/tkpng-0.9.ebuild
new file mode 100644
index 000000000000..9bff1fdda1eb
--- /dev/null
+++ b/dev-tcltk/tkpng/tkpng-0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Implements support for loading and using PNG images with Tcl/Tk"
+HOMEPAGE="http://www.muonics.com/FreeStuff/TkPNG/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}.tgz"
+
+SLOT="0"
+LICENSE="tcltk"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug threads"
+
+RDEPEND="
+ >=dev-lang/tcl-8.4:0=
+ >=dev-lang/tk-8.4:0=
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+# test target in Makefile, but test not shipped
+RESTRICT="test"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable amd64 64bit) \
+ $(use_enable threads)
+}