summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/vtcl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/vtcl')
-rw-r--r--dev-tcltk/vtcl/Manifest1
-rw-r--r--dev-tcltk/vtcl/metadata.xml12
-rw-r--r--dev-tcltk/vtcl/vtcl-1.6.0-r1.ebuild28
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-tcltk/vtcl/Manifest b/dev-tcltk/vtcl/Manifest
new file mode 100644
index 000000000000..19c2ccd2942c
--- /dev/null
+++ b/dev-tcltk/vtcl/Manifest
@@ -0,0 +1 @@
+DIST vtcl-1.6.0.tar.gz 554727 SHA256 5b95bc67f1acce46cb788c46f167dc8743e69e48289f9bb04d1b3468ef7b4652 SHA512 bfc2ed114af4bee375e820e4b1e47d394a800541eb9917204ef42481a4033927c432d7d2b005d13edd086c7c91bd594908965aae512cc4af9e5654a2bfd296de WHIRLPOOL b1fce8a4c3d6c30090dff7d6c05aff95edfc009237089b827d1100cbc43959f179f6f2ea97909eb176e779a4b00b7b93553f66bdeb42cba1d50c571adae3186c
diff --git a/dev-tcltk/vtcl/metadata.xml b/dev-tcltk/vtcl/metadata.xml
new file mode 100644
index 000000000000..9cdc0c6fea10
--- /dev/null
+++ b/dev-tcltk/vtcl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <maintainer>
+ <email>tcltk@gentoo.org</email>
+ <description>TCL / TK herd</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">vtcl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tcltk/vtcl/vtcl-1.6.0-r1.ebuild b/dev-tcltk/vtcl/vtcl-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..95db8edfa78e
--- /dev/null
+++ b/dev-tcltk/vtcl/vtcl-1.6.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Visual Tcl is a high-quality application development environment"
+HOMEPAGE="http://vtcl.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+DEPEND="dev-lang/tk"
+
+MY_DESTDIR=/usr/share/${PN}
+src_compile() {
+ ./configure || die
+ sed -i 's,^\(VTCL_HOME=\).*,\1'${MY_DESTDIR}',g' vtcl || die "Path fixing failed."
+ sed -i 's,package require -exact Tk ,package require Tk ,' lib/tkcon.tcl || die "Tcl8.5 patch failed"
+}
+
+src_install() {
+ dodir ${MY_DESTDIR} || die "Directory creation failed."
+ dobin vtcl || die
+ cp -r ./{demo,images,lib,sample,vtcl.tcl} "${D}/${MY_DESTDIR}" || die "Data installation failed."
+ dodoc ChangeLog README
+ use doc && dodoc doc/tutorial.txt
+ use doc && dohtml doc/*html
+}