summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-23 00:35:13 +0000
committerSam James <sam@gentoo.org>2022-11-23 00:35:13 +0000
commit7572adcbdc6f64953c896c0cb4f89d2980139ec3 (patch)
tree9861e2b9a2432e1c22b66d625ac70e7cbb6e3391 /dev-tcltk
parentdev-tcltk/tclxml: add link to upstream PR (diff)
downloadgentoo-7572adcbdc6f64953c896c0cb4f89d2980139ec3.tar.gz
gentoo-7572adcbdc6f64953c896c0cb4f89d2980139ec3.tar.bz2
gentoo-7572adcbdc6f64953c896c0cb4f89d2980139ec3.zip
dev-tcltk/tkpng: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tkpng/tkpng-0.9-r2.ebuild (renamed from dev-tcltk/tkpng/tkpng-0.9-r1.ebuild)22
1 files changed, 16 insertions, 6 deletions
diff --git a/dev-tcltk/tkpng/tkpng-0.9-r1.ebuild b/dev-tcltk/tkpng/tkpng-0.9-r2.ebuild
index e38d65c8ca05..a68fa63effe1 100644
--- a/dev-tcltk/tkpng/tkpng-0.9-r1.ebuild
+++ b/dev-tcltk/tkpng/tkpng-0.9-r2.ebuild
@@ -1,23 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_P="${PN}${PV}"
+inherit autotools
+
DESCRIPTION="Implements support for loading and using PNG images with Tcl/Tk"
HOMEPAGE="http://www.muonics.com/FreeStuff/TkPNG/"
SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}.tgz"
-SLOT="0"
LICENSE="tcltk"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug threads"
RDEPEND="
- >=dev-lang/tcl-8.4:0=
- >=dev-lang/tk-8.4:0=
- sys-libs/zlib"
+ >=dev-lang/tcl-8.4:=
+ >=dev-lang/tk-8.4:=
+ sys-libs/zlib
+"
DEPEND="${RDEPEND}"
# test target in Makefile, but test not shipped
@@ -25,6 +28,13 @@ RESTRICT="test"
S="${WORKDIR}"/${MY_P}
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_enable debug symbols) \