summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-09-08 19:10:06 +0200
committerUlrich Müller <ulm@gentoo.org>2019-09-08 19:31:56 +0200
commitb1c458231162cb2abd0029a3d3da9f888550c09e (patch)
tree15f5c520a7d9b8cfdc047f783a1898c6ea8e9b75 /dev-tex/catdvi/catdvi-0.14-r2.ebuild
parentdev-embedded/zmac: Bump EAPI to 7. (diff)
downloadgentoo-b1c458231162cb2abd0029a3d3da9f888550c09e.tar.gz
gentoo-b1c458231162cb2abd0029a3d3da9f888550c09e.tar.bz2
gentoo-b1c458231162cb2abd0029a3d3da9f888550c09e.zip
dev-tex/catdvi: Bump EAPI to 7.
Specify LICENSE more precisely. Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-tex/catdvi/catdvi-0.14-r2.ebuild')
-rw-r--r--dev-tex/catdvi/catdvi-0.14-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-tex/catdvi/catdvi-0.14-r2.ebuild b/dev-tex/catdvi/catdvi-0.14-r2.ebuild
new file mode 100644
index 000000000000..1f4af1e9e185
--- /dev/null
+++ b/dev-tex/catdvi/catdvi-0.14-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs flag-o-matic
+
+DESCRIPTION="DVI to plain text translator"
+HOMEPAGE="http://catdvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="virtual/tex-base
+ dev-libs/kpathsea"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-kpathsea.patch
+ eapply_user
+ eautoconf
+ has_version '>=dev-libs/kpathsea-6.2.1' \
+ && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+}
+
+src_compile() {
+ # Do not use plain emake here, because make tests
+ # may cache fonts and generate sandbox violations.
+ emake catdvi CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin catdvi
+ doman catdvi.1
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}