summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/catdvi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/catdvi')
-rw-r--r--dev-tex/catdvi/Manifest1
-rw-r--r--dev-tex/catdvi/catdvi-0.14-r1.ebuild36
-rw-r--r--dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch60
-rw-r--r--dev-tex/catdvi/metadata.xml11
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-tex/catdvi/Manifest b/dev-tex/catdvi/Manifest
new file mode 100644
index 000000000000..4fc493a86a88
--- /dev/null
+++ b/dev-tex/catdvi/Manifest
@@ -0,0 +1 @@
+DIST catdvi-0.14.tar.gz 160661 SHA256 6bface4e8a86f861d8de8ba56483ed2ace69fc0eb12c2c6d0e51e869a46b30a8 SHA512 82ea6130ec702b49ed2d2f08b968ca4d5bee6b16c7973500ceae2d412b209f38a6e63a9e80dd8d2866f190340a7758aa23ee31bed76beb35065016fea109982d WHIRLPOOL 0c4be28f029a38f456e065e52323b44c53f00c761fa3e7b4aea8539d7b9305ca386fc91094c69ea162920ba1caa5096d6d45d9b3cdd04d4cfe808e6c10e6687f
diff --git a/dev-tex/catdvi/catdvi-0.14-r1.ebuild b/dev-tex/catdvi/catdvi-0.14-r1.ebuild
new file mode 100644
index 000000000000..860bed71bc43
--- /dev/null
+++ b/dev-tex/catdvi/catdvi-0.14-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools toolchain-funcs
+
+DESCRIPTION="DVI to plain text translator"
+HOMEPAGE="http://catdvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="virtual/tex-base"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-kpathsea.patch"
+ eautoconf
+}
+
+src_compile() {
+ # Do not use plain emake here, because make tests
+ # may cache fonts and generate sandbox violations.
+ emake catdvi CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin catdvi
+ doman catdvi.1
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch b/dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch
new file mode 100644
index 000000000000..799cd1512018
--- /dev/null
+++ b/dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch
@@ -0,0 +1,60 @@
+http://bugs.gentoo.org/342817
+
+--- catdvi-0.14-orig/config.mk.in
++++ catdvi-0.14/config.mk.in
+@@ -23,6 +23,7 @@
+
+ CFG_HAS_GETOPT_LONG = @CFG_HAS_GETOPT_LONG@
+ CFG_HAS_KPATHSEA = @CFG_HAS_KPATHSEA@
++CFG_HAS_KPATHSEA_VERSION_H = @CFG_HAS_KPATHSEA_VERSION_H@
+ CFG_KPATHSEA_HAS_GETOPT_LONG = @CFG_KPATHSEA_HAS_GETOPT_LONG@
+ CFG_SHOW_PSE2UNIC_WARNINGS = @CFG_SHOW_PSETOUNIC_WARNINGS@
+
+--- catdvi-0.14-orig/configure.in
++++ catdvi-0.14/configure.in
+@@ -48,6 +48,9 @@
+ AC_MSG_ERROR([*** kpathsea library (required) not found; try to use the --with-kpathsea-prefix option ***])
+ fi
+
++AC_CHECK_HEADERS([kpathsea/version.h], CFG_HAS_KPATHSEA_VERSION_H=yes, CFG_HAS_KPATHSEA_VERSION_H=no)
++AC_SUBST(CFG_HAS_KPATHSEA_VERSION_H)
++
+ dnl It seem libkpathsea provides a getopt_long() implementation
+ dnl if and only if the C library does not.
+ dnl
+--- catdvi-0.14-orig/GNUmakefile
++++ catdvi-0.14/GNUmakefile
+@@ -36,6 +36,10 @@
+ endif
+ endif
+
++ifeq ($(CFG_HAS_KPATHSEA_VERSION_H),yes)
++CPPFLAGS += -DCFG_HAS_KPATHSEA_VERSION_H
++endif
++
+ ifeq ($(CFG_HAS_KPATHSEA),yes)
+ FINDTFM = kpathsea.o
+ LDLIBS = -lkpathsea
+--- catdvi-0.14-orig/kpathsea.c
++++ catdvi-0.14/kpathsea.c
+@@ -21,6 +21,12 @@
+ #include "findtfm.h"
+ #include "version.h"
+
++#ifdef CFG_HAS_KPATHSEA_VERSION_H
++#include <kpathsea/version.h>
++#else
++extern char * kpathsea_version_string;
++#endif
++
+ void setup_findtfm(char const * progname)
+ {
+ kpse_set_program_name(progname, PACKAGE);
+@@ -36,7 +42,6 @@
+
+ void version_findtfm(void)
+ {
+- extern char * kpathsea_version_string;
+ puts(kpathsea_version_string);
+ }
+
diff --git a/dev-tex/catdvi/metadata.xml b/dev-tex/catdvi/metadata.xml
new file mode 100644
index 000000000000..8149b587c670
--- /dev/null
+++ b/dev-tex/catdvi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <maintainer>
+ <email>ulm@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">catdvi</remote-id>
+ </upstream>
+</pkgmetadata>