summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/cpp2latex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/cpp2latex')
-rw-r--r--dev-tex/cpp2latex/Manifest1
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild31
-rw-r--r--dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch12
-rw-r--r--dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch15
-rw-r--r--dev-tex/cpp2latex/files/cpp2latex-2.3.patch44
-rw-r--r--dev-tex/cpp2latex/metadata.xml5
6 files changed, 108 insertions, 0 deletions
diff --git a/dev-tex/cpp2latex/Manifest b/dev-tex/cpp2latex/Manifest
new file mode 100644
index 000000000000..f9c92af75d7e
--- /dev/null
+++ b/dev-tex/cpp2latex/Manifest
@@ -0,0 +1 @@
+DIST cpp2latex-2.3.tar.gz 483213 SHA256 bd2ede885f34f5412734b2ec28cc454b6ce0ae3cc89b9a0cfe9df4baa075af86 SHA512 af4a13a79b2eb14556f35ca372a0c4f5fec5ddc52a712e998fb73dfe0451c1d95eb857f905a9fd66fac72f734fdcad50b9bca2769780950c7b04fa56912812e1 WHIRLPOOL b34d5611bf2af53b5dd9cc5dd2002f795d894ba87d00072160080b7655959eae64f902e5af04cd22e0fee58d46930ede53e7a2f03e808235e91800eb56de8b5c
diff --git a/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild b/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
new file mode 100644
index 000000000000..639627f76a96
--- /dev/null
+++ b/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A program to convert C++ code to LaTeX source"
+HOMEPAGE="http://www.arnoldarts.de/drupal/?q=Cpp2LaTeX"
+SRC_URI="http://www.arnoldarts.de/drupal/files/downloads/cpp2latex/${P}.tar.gz"
+LICENSE="GPL-2"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+# although it makes sense to have tex installed, it is
+# neither a compile or runtime dependency
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/cpp2latex"
+ # bug 44585
+ epatch "${FILESDIR}/cpp2latex-2.3.patch"
+ # bug #227863
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-tests.patch"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+}
diff --git a/dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch b/dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch
new file mode 100644
index 000000000000..006560506676
--- /dev/null
+++ b/dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch
@@ -0,0 +1,12 @@
+Index: cpp2latex-2.3/cpp2latex/main.cpp
+===================================================================
+--- cpp2latex-2.3.orig/cpp2latex/main.cpp
++++ cpp2latex-2.3/cpp2latex/main.cpp
+@@ -22,6 +22,7 @@
+ #include <iostream>
+ #include <stdlib.h>
+ #include <string>
++#include <cstring>
+ #include <fstream>
+ #include <vector>
+ #include <stdio.h>
diff --git a/dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch b/dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch
new file mode 100644
index 000000000000..621c43d28156
--- /dev/null
+++ b/dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch
@@ -0,0 +1,15 @@
+Index: cpp2latex-2.3/cpp2latex/getopttest.cpp
+===================================================================
+--- cpp2latex-2.3.orig/cpp2latex/getopttest.cpp
++++ cpp2latex-2.3/cpp2latex/getopttest.cpp
+@@ -2,7 +2,9 @@
+ #include <iostream>
+ #include <getopt.h>
+
+-void main( int argc, char* argv[] )
++using namespace std;
++
++int main( int argc, char* argv[] )
+ {
+ int optch=0, optc=1;
+ while( ( optch = getopt( argc,argv, "h:a:k" ) ) > 0 )
diff --git a/dev-tex/cpp2latex/files/cpp2latex-2.3.patch b/dev-tex/cpp2latex/files/cpp2latex-2.3.patch
new file mode 100644
index 000000000000..676b5ef3136c
--- /dev/null
+++ b/dev-tex/cpp2latex/files/cpp2latex-2.3.patch
@@ -0,0 +1,44 @@
+--- main.cpp Thu Mar 6 08:15:36 2003
++++ main.cpp Tue Jan 24 21:47:17 2006
+@@ -27,12 +27,14 @@
+ #include <stdio.h>
+ #include <getopt.h>
+
++using namespace std;
++
+ struct replace{
+ std::string voraus;
+ std::string ersetzt;
+ };
+
+-std::vector <replace> rules;
++std::vector<struct replace> rules;
+ std::string syntax( std::ifstream *src, char *c );
+ void initReplace();
+ bool satzzeichen( char c );
+@@ -162,9 +164,13 @@
+ if( comment && !comment1 )
+ {
+ file.get(c);
+- if(c=='/') { out+="/}"; comment=false; }
+- else { if(c=='\n') out+="\\\\"; }
+- if( !( (c=='*')||(c=='/') )) out+=c;
++ if(c=='/') {
++ out+="/}";
++ comment=false;
++ } else if (c=='\n') out+="\\\\";
++ /* .alex. 1 line substitution*/
++ else file.seekg(-1,ios::cur);
++ //if( !( (c=='*')||(c=='/') )) out+=c;
+ }
+ break;
+
+@@ -323,7 +329,7 @@
+ /** initialize the replacementrules */
+ void initReplace()
+ {
+-replace dummy;
++ struct replace dummy;
+ dummy.voraus = "and"; dummy.ersetzt = "\\textbf{and}"; rules.push_back(dummy);
+ dummy.voraus = "and_eq"; dummy.ersetzt = "\\textbf{and\\underline\\ eq}"; rules.push_back(dummy);
+ dummy.voraus = "asm"; dummy.ersetzt = "\\textbf{asm}"; rules.push_back(dummy);
diff --git a/dev-tex/cpp2latex/metadata.xml b/dev-tex/cpp2latex/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/dev-tex/cpp2latex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>