summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/curve
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/curve')
-rw-r--r--dev-tex/curve/Manifest1
-rw-r--r--dev-tex/curve/curve-1.16.ebuild39
-rw-r--r--dev-tex/curve/metadata.xml5
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-tex/curve/Manifest b/dev-tex/curve/Manifest
new file mode 100644
index 000000000000..f6e383574900
--- /dev/null
+++ b/dev-tex/curve/Manifest
@@ -0,0 +1 @@
+DIST curve-1.16.zip 279634 SHA256 d369e9a0ddec13cb0fe069fdfb6b219ebb2fdef483cbc305de8ef80eb4436f15 SHA512 3e017dc1e16084513e3d1476d8a6947c8bb6b1b71ae532842bcded186841bfe668dc46ded1200dd835fc258dcdebf0707626cf60d0af752694a377f14739ddbf WHIRLPOOL c2ef53423b14b528bf4fed32588dd98136f31fea05fc136d53073723ba8d5e0b8de55e91f5cedebdae80b87e72c6b285b10aa302db437382024ea68b8db8364a
diff --git a/dev-tex/curve/curve-1.16.ebuild b/dev-tex/curve/curve-1.16.ebuild
new file mode 100644
index 000000000000..179f375c40e7
--- /dev/null
+++ b/dev-tex/curve/curve-1.16.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit latex-package
+
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="LaTeX style for a CV (curriculum vitae) with flavour option"
+SRC_URI="ftp://tug.ctan.org/pub/tex-archive/macros/latex/contrib/${PN}.zip -> ${P}.zip"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/curve/"
+LICENSE="LPPL-1.2"
+RDEPEND=">=dev-texlive/texlive-latexextra-2010"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+IUSE="doc examples"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+
+ latex-package_src_doinstall styles
+
+ dodoc README NEWS THANKS
+
+ if use doc ; then
+ latex-package_src_doinstall pdf
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/example
+ doins examples/*
+ fi
+}
diff --git a/dev-tex/curve/metadata.xml b/dev-tex/curve/metadata.xml
new file mode 100644
index 000000000000..21ff3a538481
--- /dev/null
+++ b/dev-tex/curve/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+</pkgmetadata>