summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-11 23:32:02 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-11 23:32:25 +0100
commit44ec1932b03923f8213eba239561ee2ef7d2fcfc (patch)
tree52a3a19c5d4bda15c4abddde6e92dbf9104cfd98 /dev-tex/hlatex/hlatex-1.0.1-r1.ebuild
parentnet-dns/avahi: Don't call moc directly (diff)
downloadgentoo-44ec1932b03923f8213eba239561ee2ef7d2fcfc.tar.gz
gentoo-44ec1932b03923f8213eba239561ee2ef7d2fcfc.tar.bz2
gentoo-44ec1932b03923f8213eba239561ee2ef7d2fcfc.zip
dev-tex/hlatex: EAPI bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-tex/hlatex/hlatex-1.0.1-r1.ebuild')
-rw-r--r--dev-tex/hlatex/hlatex-1.0.1-r1.ebuild115
1 files changed, 115 insertions, 0 deletions
diff --git a/dev-tex/hlatex/hlatex-1.0.1-r1.ebuild b/dev-tex/hlatex/hlatex-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..c1cf71c7a38a
--- /dev/null
+++ b/dev-tex/hlatex/hlatex-1.0.1-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs latex-package
+
+MY_P="HLaTeX-${PV}"
+DESCRIPTION="HLaTeX is a LaTeX package to use Hangul with LaTeX"
+HOMEPAGE="http://project.ktug.or.kr/hlatex/"
+UHCFONTS="uhc-myoungjo-1.0.tar.gz
+ uhc-gothic-1.0.tar.gz
+ uhc-taza-1.0.tar.gz
+ uhc-graphic-1.0.tar.gz
+ uhc-gungseo-1.0.tar.gz
+ uhc-shinmun-1.0.tar.gz
+ uhc-pilgi-1.0.tar.gz
+ uhc-pen-1.0.tar.gz
+ uhc-bom-1.0.tar.gz
+ uhc-yetgul-1.0.tar.gz
+ uhc-jamo-1.0.tar.gz
+ uhc-vada-1.0.tar.gz
+ uhc-pilgia-1.0.tar.gz
+ uhc-dinaru-1.0.tar.gz"
+
+SRC_URI="ftp://ftp.ktug.or.kr/pub/ktug/hlatex/${MY_P}.tar.gz
+ ftp://ftp.ktug.or.kr/pub/ktug/hlatex/fonts/uhc-fonts-1.0.tar.gz
+ ${UHCFONTS//uhc-/ftp://ftp.ktug.or.kr/pub/ktug/hlatex/fonts/uhc-}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S="${WORKDIR}/HLaTeX"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ unpack uhc-fonts-1.0.tar.gz
+ cd "${S}"/contrib
+ cat >Makefile <<-EOF
+CC=$(tc-getCC)
+all: hmakeindex hbibtex
+hmakeindex: hmakeindex.c
+hbibtex: hbibtex.c
+EOF
+}
+
+src_compile() {
+ cd "${S}"/contrib
+ emake
+}
+
+src_install() {
+ cd "${S}"/latex
+ insinto ${TEXMF}/tex/latex/hlatex
+ doins *
+
+ cd "${S}"/lambda
+ insinto ${TEXMF}/tex/lambda/hlatex
+ doins u8hangul.tex uhc-test.tex uhc*.fd
+
+ insinto ${TEXMF}/omega/otp/hlatex
+ doins hlatex.otp
+
+ insinto ${TEXMF}/omega/ocp/hlatex
+ doins hlatex.ocp
+
+ cd "${S}"/contrib
+ insinto ${TEXMF}/tex/latex/hlatex
+ doins hbname-k.tex khyper.sty showhkeys.sty showhtags.sty
+ doins hangulfn.sty hfn-k.tex
+
+ insinto ${TEXMF}/tex/lambda/hlatex
+ doins hbname-u.tex hfn-u.tex
+
+ insinto ${TEXMF}/bibtex/bst/hlatex
+ doins halpha.bst
+
+ insinto ${TEXMF}/makeindex
+ doins hind.ist hglo.ist
+
+ dobin hmakeindex hbibtex
+
+ cd "${S}"
+ dodoc ChangeLog.ko NEWS* README.en
+
+ cd "${WORKDIR}"/uhc-fonts-1.0
+ insinto ${TEXMF}/fonts/map/hlatex
+ doins uhc-base.map uhc-extra.map
+
+ cd "${ED}"/${TEXMF}/fonts
+ for X in ${UHCFONTS}
+ do
+ unpack ${X}
+ done
+}
+
+pkg_postinst() {
+ updmap-sys --enable Map=uhc-base.map
+ updmap-sys --enable Map=uhc-extra.map
+ texhash
+}
+
+pkg_postrm() {
+ if [ ! -e "${EPREFIX}"${TEXMF}/fonts/map/hlatex/uhc-base.map ] ; then
+ updmap-sys --disable Map=uhc-base.map
+ fi
+
+ if [ ! -e "${EPREFIX}"${TEXMF}/fonts/map/hlatex/uhc-extra.map ] ; then
+ updmap-sys --disable Map=uhc-extra.map
+ fi
+
+ texhash
+}