summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew White <mehw.is.me@inventati.org>2021-11-11 23:28:48 +0100
committerSam James <sam@gentoo.org>2021-11-12 01:22:51 +0000
commit2437b4f4066252a5e8714dca6ce3c9f6b54823ed (patch)
treefa003fae33395f7caad5db3f64d88f8a758a4dc3 /dev-tex/latex2html
parentnet-misc/clusterssh: sync live ebuild (diff)
downloadgentoo-2437b4f4066252a5e8714dca6ce3c9f6b54823ed.tar.gz
gentoo-2437b4f4066252a5e8714dca6ce3c9f6b54823ed.tar.bz2
gentoo-2437b4f4066252a5e8714dca6ce3c9f6b54823ed.zip
dev-tex/latex2html: fix pstoim.pl PNMCROPOPT
Apply upstream patch. Closes: https://bugs.gentoo.org/823188 Package-Manager: Portage-3.0.28, Repoman-3.0.3-r1 Signed-off-by: Matteo Bianco <mehw.is.me@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/22907 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-tex/latex2html')
-rw-r--r--dev-tex/latex2html/files/latex2html-2021.2-fix-PNMCROPOPT.patch31
-rw-r--r--dev-tex/latex2html/latex2html-2021.2-r2.ebuild82
2 files changed, 113 insertions, 0 deletions
diff --git a/dev-tex/latex2html/files/latex2html-2021.2-fix-PNMCROPOPT.patch b/dev-tex/latex2html/files/latex2html-2021.2-fix-PNMCROPOPT.patch
new file mode 100644
index 000000000000..78d7bab3eeb4
--- /dev/null
+++ b/dev-tex/latex2html/files/latex2html-2021.2-fix-PNMCROPOPT.patch
@@ -0,0 +1,31 @@
+From ea0ae1cf6789cf8f29bf07406ef6e91918b6bfc3 Mon Sep 17 00:00:00 2001
+From: Matthew White <mehw.is.me@inventati.org>
+Date: Wed, 10 Nov 2021 00:32:14 +0000
+Subject: [PATCH] fix pnmcrop duplicated -sides option (aka PNMCROPOPT)
+
+If the variable PNMCROPOPT is defined as "-sides" via config/config.pl
+in pstoimg.bin, calling `pnmcrop -bot -sides $PNMCROPOPT` will give an
+error, due to the duplicated option.
+---
+ pstoimg.pin | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pstoimg.pin b/pstoimg.pin
+index 2c4f3e4..588b987 100755
+--- a/pstoimg.pin
++++ b/pstoimg.pin
+@@ -1300,9 +1300,9 @@ sub crop_scale_etc {
+ my $edge = $1;
+ my $croparg = '';
+ if($edge =~ /b/i) {
+- $croparg = "-bot -sides $PNMCROPOPT ";
++ $croparg = "-bot -sides ";
+ } elsif($edge =~ /[tlr]/i) {
+- $croparg = "-$edge -sides $PNMCROPOPT ";
++ $croparg = "-$edge -sides ";
+ } elsif($edge =~ /s/i) {
+ #RRM: shave at most 1-2 rows of white from the bottom
+ #if @pipes@
+--
+2.32.0
+
diff --git a/dev-tex/latex2html/latex2html-2021.2-r2.ebuild b/dev-tex/latex2html/latex2html-2021.2-r2.ebuild
new file mode 100644
index 000000000000..f4a54dda7ee4
--- /dev/null
+++ b/dev-tex/latex2html/latex2html-2021.2-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Convertor written in Perl that converts LaTeX documents to HTML"
+HOMEPAGE="https://www.latex2html.org/"
+SRC_URI="https://github.com/latex2html/latex2html/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="gif png"
+
+DEPEND="
+ app-text/ghostscript-gpl
+ virtual/latex-base
+ >=media-libs/netpbm-10.86.24
+ dev-lang/perl
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng:0 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2021.2-fix-PNMCROPOPT.patch
+ "${FILESDIR}"/${PN}-2021.2-respect-DESTDIR.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's%@PERL@%'"${EPREFIX}"'/usr/bin/perl%g' wrapper/unix.pin || die
+}
+
+src_configure() {
+ local myconf
+
+ use gif || use png || myconf+=" --disable-images"
+
+ econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/latex2html \
+ --shlibdir="${EPREFIX}"/usr/$(get_libdir)/latex2html \
+ --enable-pk \
+ --enable-eps \
+ --enable-reverse \
+ --enable-pipes \
+ --enable-paths \
+ --enable-wrapper \
+ --with-texpath="${EPREFIX}"/usr/share/texmf-site/tex/latex/html \
+ --without-mktexlsr \
+ $(use_enable gif) \
+ $(use_enable png) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # make /usr/share/latex2html sticky
+ keepdir /usr/share/latex2html
+
+ # clean the perl scripts up to remove references to the sandbox
+ local dir="${ED}/usr/$(get_libdir)/latex2html"
+ if use png || use gif; then
+ # pstoimg isn't built unless gif or png useflags are enabled
+ sed -i -e "s:${T}:/tmp:g" "${dir}"/pstoimg.pl || die
+ fi
+
+ sed -i -e "s:${S}::g" "${dir}"/latex2html.pl || die
+ sed -i -e "s:${T}:/tmp:g" "${dir}"/cfgcache.pm || die
+ sed -i -e "s:${T}:/tmp:g" "${dir}"/l2hconf.pm || die
+
+ dodoc BUGS Changes FAQ MANIFEST README.md TODO
+}
+
+pkg_postinst() {
+ "${EROOT}"/usr/bin/mktexlsr
+}
+
+pkg_postrm() {
+ "${EROOT}"/usr/bin/mktexlsr
+}