summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-23 14:33:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-23 14:36:20 +0200
commit122a77acb7470031575e5deb728a98a10650e5fe (patch)
tree43d36358b6348697d06792dafd68bcf468e68514 /dev-tex/latex2rtf/latex2rtf-2.3.15.ebuild
parentapp-text/ocrad: bump to 0.26 (diff)
downloadgentoo-122a77acb7470031575e5deb728a98a10650e5fe.tar.gz
gentoo-122a77acb7470031575e5deb728a98a10650e5fe.tar.bz2
gentoo-122a77acb7470031575e5deb728a98a10650e5fe.zip
dev-tex/latex2rtf: bump to 2.3.15
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-tex/latex2rtf/latex2rtf-2.3.15.ebuild')
-rw-r--r--dev-tex/latex2rtf/latex2rtf-2.3.15.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-tex/latex2rtf/latex2rtf-2.3.15.ebuild b/dev-tex/latex2rtf/latex2rtf-2.3.15.ebuild
new file mode 100644
index 000000000000..8b58602ce8ac
--- /dev/null
+++ b/dev-tex/latex2rtf/latex2rtf-2.3.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="LaTeX to RTF converter"
+HOMEPAGE="http://latex2rtf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/latex2rtf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+S="${WORKDIR}/${P%b}"
+
+RDEPEND="
+ virtual/latex-base
+ media-gfx/imagemagick
+"
+DEPEND="${RDEPEND}
+ virtual/texi2dvi
+ test? (
+ dev-texlive/texlive-langgerman
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexextra
+ dev-tex/latex2html
+ )
+"
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ tc-export CC
+ # Set DESTDIR here too so that compiled-in paths are correct.
+ emake DESTDIR="${EPREFIX}/usr" || die "emake failed"
+
+ # Needed for tests
+ chmod +x test/bracecheck || die
+
+ cd "${S}/doc"
+ emake realclean
+ emake -j1
+}
+
+src_install() {
+ dodoc README* HACKING ToDo ChangeLog doc/credits
+ emake DESTDIR="${ED}/usr" -j1 install install-info
+}