summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-07 16:13:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-08 16:19:02 +0200
commit71ce0bf88c47f0657c73335f9d7859cc70f3709a (patch)
tree157a9321943e0df86dd3e09ad25dd7af78b5320d /dev-tex/latexdiff/latexdiff-1.2.0-r1.ebuild
parentapp-office/lyx: Adapt deps for texlive 2017 (diff)
downloadgentoo-71ce0bf88c47f0657c73335f9d7859cc70f3709a.tar.gz
gentoo-71ce0bf88c47f0657c73335f9d7859cc70f3709a.tar.bz2
gentoo-71ce0bf88c47f0657c73335f9d7859cc70f3709a.zip
dev-tex/latexdiff: revbump to propagate dep fix
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-tex/latexdiff/latexdiff-1.2.0-r1.ebuild')
-rw-r--r--dev-tex/latexdiff/latexdiff-1.2.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-tex/latexdiff/latexdiff-1.2.0-r1.ebuild b/dev-tex/latexdiff/latexdiff-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..8507a0ba4ebb
--- /dev/null
+++ b/dev-tex/latexdiff/latexdiff-1.2.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Compare two latex files and mark up significant differences"
+HOMEPAGE="http://www.ctan.org/tex-archive/support/latexdiff/ https://github.com/ftilmann/latexdiff/"
+SRC_URI="https://github.com/ftilmann/latexdiff/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="test"
+
+RDEPEND=">=dev-lang/perl-5.8
+ virtual/latex-base
+ || ( dev-texlive/texlive-plaingeneric dev-texlive/texlive-genericrecommended )
+ dev-perl/Algorithm-Diff"
+DEPEND="${RDEPEND}
+ dev-perl/Pod-LaTeX
+ test? ( app-shells/tcsh )"
+
+src_compile() {
+ PATH="${S}/dist:${PATH}" emake -j1 distribution
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ cd dist || die
+ dobin latexdiff latexrevise latexdiff-vc
+ doman latexdiff.1 latexrevise.1 latexdiff-vc.1
+ dodoc README doc/latexdiff-man.pdf
+}