summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-01-19 17:25:05 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-01-19 17:25:05 +0300
commit5399484cc912bccd2810a149f1fbdfb73c7caaf6 (patch)
tree5d01ecf87bffbe23205cefb7bf506ba7bd01c72e /dev-tex/pythontex
parentdev-tex/biblatex-apa: Drop old (diff)
downloadgentoo-5399484cc912bccd2810a149f1fbdfb73c7caaf6.tar.gz
gentoo-5399484cc912bccd2810a149f1fbdfb73c7caaf6.tar.bz2
gentoo-5399484cc912bccd2810a149f1fbdfb73c7caaf6.zip
dev-tex/pythontex: port to EAPI=7
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-tex/pythontex')
-rw-r--r--dev-tex/pythontex/pythontex-0.16.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-tex/pythontex/pythontex-0.16.ebuild b/dev-tex/pythontex/pythontex-0.16.ebuild
index af900b7b2250..267d1e510960 100644
--- a/dev-tex/pythontex/pythontex-0.16.ebuild
+++ b/dev-tex/pythontex/pythontex-0.16.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit latex-package python-r1
@@ -28,10 +28,8 @@ TEXMF=/usr/share/texmf-site
src_compile() {
cd ${PN} || die
- ebegin "Compiling ${PN}"
rm ${PN}.sty || die
VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
- eend
}
src_install() {
@@ -40,11 +38,7 @@ src_install() {
cd ${PN} || die
installation() {
- if python_is_python3; then
- python_domodule {de,}${PN}3.py
- else
- python_domodule {de,}${PN}2.py
- fi
+ python_domodule {de,}${PN}3.py
python_domodule ${PN}_{engines,utils}.py
python_doscript {de,}${PN}.py syncpdb.py
python_optimize