summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-16 17:41:09 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-16 17:43:39 -0700
commit9838d41271b22d47e1b2845a618170cd63bcffef (patch)
treeb785e6debb8fc647f2f135ebc3ff34ff541188bb /dev-tex/xmltex
parentmedia-libs/vigra: python3_8 support (diff)
downloadgentoo-9838d41271b22d47e1b2845a618170cd63bcffef.tar.gz
gentoo-9838d41271b22d47e1b2845a618170cd63bcffef.tar.bz2
gentoo-9838d41271b22d47e1b2845a618170cd63bcffef.zip
dev-tex/xmltex: Unpack with /bin/gzip explicitly
... in order to work around an incompatibility in app-arch/pigz. It appears that xmltex's tarball has trailing junk at the end of the file, and it appears to be a completed project, so no new releases are forthcoming. Closes: https://bugs.gentoo.org/645438 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-tex/xmltex')
-rw-r--r--dev-tex/xmltex/xmltex-1.9-r3.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-tex/xmltex/xmltex-1.9-r3.ebuild b/dev-tex/xmltex/xmltex-1.9-r3.ebuild
index 177068ab9258..5b9a6f94c672 100644
--- a/dev-tex/xmltex/xmltex-1.9-r3.ebuild
+++ b/dev-tex/xmltex/xmltex-1.9-r3.ebuild
@@ -22,6 +22,11 @@ DEPEND="virtual/latex-base"
RDEPEND="${DEPEND}"
+src_unpack() {
+ # Bug 645438
+ tar -I /bin/gzip -xf "${DISTDIR}"/${P}.tar.gz || die
+}
+
src_compile() {
fmt_call="$(has_version '>=app-text/texlive-core-2019' \
&& echo "fmtutil-user" || echo "fmtutil")"