summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-17 23:39:25 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-17 23:39:25 +0100
commit8fd8a9ea64cefee9af92ad3b10748fbe1f5c6f63 (patch)
tree07a276b4cfa24d5b335c5393a19b5539108c53ef /dev-tex
parentdev-tex/dvi2gr: Remove old, bug 648050 (diff)
downloadgentoo-8fd8a9ea64cefee9af92ad3b10748fbe1f5c6f63.tar.gz
gentoo-8fd8a9ea64cefee9af92ad3b10748fbe1f5c6f63.tar.bz2
gentoo-8fd8a9ea64cefee9af92ad3b10748fbe1f5c6f63.zip
dev-tex/dvipost: EAPI bump
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/dvipost/dvipost-1.1-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-tex/dvipost/dvipost-1.1-r3.ebuild b/dev-tex/dvipost/dvipost-1.1-r3.ebuild
new file mode 100644
index 000000000000..a55059cb3298
--- /dev/null
+++ b/dev-tex/dvipost/dvipost-1.1-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit latex-package eutils toolchain-funcs
+
+DESCRIPTION="post processor for dvi files"
+HOMEPAGE="http://efeu.cybertec.at/index_en.html"
+SRC_URI="http://efeu.cybertec.at/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ tc-export CC
+ eapply "${FILESDIR}"/${PV}-ldflags.patch
+ default
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin dvipost
+ dosym dvipost /usr/bin/pptex
+ dosym dvipost /usr/bin/pplatex
+
+ insinto ${TEXMF}/tex/latex/misc/
+ insopts -m0644
+ doins dvipost.sty
+
+ dodoc dvipost.doc CHANGELOG NOTES README dvipost.html
+ newman "${S}"/dvipost.man dvipost.1
+}