summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-09 15:08:22 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-09 15:08:22 -0500
commitbdd1dd010d6e892c707a94880e31a259a48d5613 (patch)
treefcc2c2fc04821323cab33e9f1b5d764d74356c07 /dev-tex
parentdev-tex/detex: bump EAPI and stuff (diff)
downloadgentoo-bdd1dd010d6e892c707a94880e31a259a48d5613.tar.gz
gentoo-bdd1dd010d6e892c707a94880e31a259a48d5613.tar.bz2
gentoo-bdd1dd010d6e892c707a94880e31a259a48d5613.zip
dev-tex/envlab: EAPI bump and stuff
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/envlab/envlab-1.2-r1.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/dev-tex/envlab/envlab-1.2-r1.ebuild b/dev-tex/envlab/envlab-1.2-r1.ebuild
index a2b0ea366cfe..c89d0ec77c37 100644
--- a/dev-tex/envlab/envlab-1.2-r1.ebuild
+++ b/dev-tex/envlab/envlab-1.2-r1.ebuild
@@ -1,32 +1,35 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit latex-package
-S="${WORKDIR}/${PN}"
-LICENSE="LPPL-1.2"
DESCRIPTION="A LaTeX module to format envelopes"
HOMEPAGE="https://ctan.org/pkg/envlab"
-# downloaded from
+# downloaded from:
# ftp://ftp.ctan.org/pub/tex-archive/macros/latex/contrib/${PN}.tar.gz
SRC_URI="mirror://gentoo/${P}.tar.gz"
-SLOT="0"
-DEPEND=""
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
IUSE=""
+DEPEND=""
+
TEXMF=/usr/share/texmf-site
+S="${WORKDIR}/${PN}"
+
src_compile() {
export VARTEXFONTS="${T}/fonts"
ebegin "Compiling ${PN}"
- latex envlab.ins || die
- pdflatex elguide.tex || die
- pdflatex elguide.tex || die
- pdflatex envlab.drv || die
- pdflatex envlab.drv || die
+ latex envlab.ins || die "compiling #1 failed"
+ pdflatex elguide.tex || die "compiling #2 failed"
+ pdflatex elguide.tex || die "compiling #2 failed"
+ pdflatex envlab.drv || die "compiling #3 failed"
+ pdflatex envlab.drv || die "compiling #3 failed"
eend
}