summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-texlive/texlive-xetex/texlive-xetex-2012.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-texlive/texlive-xetex/texlive-xetex-2012.ebuild')
-rw-r--r--dev-texlive/texlive-xetex/texlive-xetex-2012.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-texlive/texlive-xetex/texlive-xetex-2012.ebuild b/dev-texlive/texlive-xetex/texlive-xetex-2012.ebuild
new file mode 100644
index 000000000000..cd2cc5bab355
--- /dev/null
+++ b/dev-texlive/texlive-xetex/texlive-xetex-2012.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+TEXLIVE_MODULE_CONTENTS="arabxetex euenc fixlatvian fontbook fontwrap mathspec philokalia polyglossia realscripts unisugar xecjk xecolor xecyr xeindex xepersian xesearch xetex xetex-def xetex-itrans xetex-pstricks xetexconfig xetexfontinfo xltxtra xunicode collection-xetex
+"
+TEXLIVE_MODULE_DOC_CONTENTS="arabxetex.doc euenc.doc fixlatvian.doc fontbook.doc fontwrap.doc mathspec.doc philokalia.doc polyglossia.doc realscripts.doc unisugar.doc xecjk.doc xecolor.doc xecyr.doc xeindex.doc xepersian.doc xesearch.doc xetex.doc xetex-itrans.doc xetex-pstricks.doc xetexfontinfo.doc xltxtra.doc xunicode.doc "
+TEXLIVE_MODULE_SRC_CONTENTS="arabxetex.source euenc.source fixlatvian.source fontbook.source philokalia.source polyglossia.source realscripts.source xecjk.source xepersian.source xltxtra.source "
+inherit font texlive-module
+DESCRIPTION="TeXLive XeTeX packages"
+
+LICENSE="GPL-2 Apache-2.0 GPL-1 LPPL-1.3 OFL public-domain TeX-other-free"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+DEPEND=">=dev-texlive/texlive-basic-2012
+!=app-text/texlive-core-2007*
+>=dev-texlive/texlive-latexextra-2010
+>=app-text/texlive-core-2010[xetex]
+>=dev-texlive/texlive-genericrecommended-2010
+>=dev-texlive/texlive-mathextra-2012
+!<dev-texlive/texlive-mathextra-2012
+"
+RDEPEND="${DEPEND} "
+FONT_CONF=( "${FILESDIR}"/09-texlive.conf )
+
+src_install() {
+ texlive-module_src_install
+ font_fontconfig
+}
+
+pkg_postinst() {
+ texlive-module_pkg_postinst
+ font_pkg_postinst
+}
+
+pkg_postrm() {
+ texlive-module_pkg_postrm
+ font_pkg_postrm
+}