summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-09-29 01:40:49 +0800
committerJason Zaman <perfinion@gentoo.org>2018-09-29 18:20:22 +0800
commit8b026d59bb6900697f39255c45e5033572b25c24 (patch)
treec9d150ca156506c6a1e08eaee228f790519f8842 /dev-util/android-studio
parentdev-util/android-studio: drop old (diff)
downloadgentoo-8b026d59bb6900697f39255c45e5033572b25c24.tar.gz
gentoo-8b026d59bb6900697f39255c45e5033572b25c24.tar.bz2
gentoo-8b026d59bb6900697f39255c45e5033572b25c24.zip
dev-util/android-studio: bump to 3.2.0
Closes: https://bugs.gentoo.org/667028 Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'dev-util/android-studio')
-rw-r--r--dev-util/android-studio/Manifest1
-rw-r--r--dev-util/android-studio/android-studio-3.2.0.26.181.5014246.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/dev-util/android-studio/Manifest b/dev-util/android-studio/Manifest
index 38833aa6b927..25521ef88d35 100644
--- a/dev-util/android-studio/Manifest
+++ b/dev-util/android-studio/Manifest
@@ -1 +1,2 @@
DIST android-studio-ide-173.4907809-linux.zip 897596053 BLAKE2B 6142cfc21d41a23d93ff064be457a28879ce80830bec79a38f6862d0f5b9de7b552d7175d7bf3e3ddfc70b10e0f7313e7ebcb7a3cdf16511c070551a27193775 SHA512 3fc01ffef5dd88dce088cc67fde03c62dadce7a700aace17ebd414ad0b1125b8370b5f132349424ff65ffc721ff383e6793737a0021826f08e35c893e33535be
+DIST android-studio-ide-181.5014246-linux.zip 1054392038 BLAKE2B 455ce3455710d0709746dc9c18caf61fd347f6c157873de54821601846be6e086646d6261d2c9bdd6986d8f2874e7a90c37b0db820326d2eb17afe438954e240 SHA512 37c622cab6d21e8a0e6d38e0f8c29e22910647df3e6d93ee86c71a39f171b1b51952a13eae2660e209c2eb7a093a9f7d2177562ea287353a30507b22c2617bd0
diff --git a/dev-util/android-studio/android-studio-3.2.0.26.181.5014246.ebuild b/dev-util/android-studio/android-studio-3.2.0.26.181.5014246.ebuild
new file mode 100644
index 000000000000..ec9300dae613
--- /dev/null
+++ b/dev-util/android-studio/android-studio-3.2.0.26.181.5014246.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils java-pkg-2 eapi7-ver
+
+RESTRICT="strip"
+QA_PREBUILT="opt/${PN}/bin/libbreakgen*.so
+ opt/${PN}/bin/fsnotifier*
+ opt/${PN}/bin/lldb/*
+ opt/${PN}/lib/libpty/linux/x86*/libpty.so
+ opt/${PN}/plugins/android/lib/libwebp_jni*.so
+ opt/${PN}/plugins/android/resources/perfa/*/libperfa.so
+ opt/${PN}/plugins/android/resources/perfd/*/perfd
+ opt/${PN}/plugins/android/resources/simpleperf/*/simpleperf"
+
+VER_CMP=( $(ver_rs 1- ' ') )
+if [[ ${#VER_CMP[@]} -eq 6 ]]; then
+ STUDIO_V=$(ver_cut 1-4)
+ BUILD_V=$(ver_cut 5-6)
+else
+ STUDIO_V=$(ver_cut 1-3)
+ BUILD_V=$(ver_cut 4-5)
+fi
+
+DESCRIPTION="A new Android development environment based on IntelliJ IDEA"
+HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
+SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="selinux"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/zip
+ dev-java/commons-logging:0
+ dev-java/log4j:0"
+
+# dev-java/guava:18
+RDEPEND=">=virtual/jdk-1.7
+ selinux? ( sec-policy/selinux-android )
+ >=app-arch/bzip2-1.0.6-r4
+ dev-java/commons-logging:0
+ dev-java/log4j:0
+ >=dev-libs/expat-2.1.0-r3
+ >=dev-libs/libffi-3.0.13-r1
+ >=media-libs/fontconfig-2.10.92
+ >=media-libs/freetype-2.5.5
+ >=media-libs/libpng-1.2.51
+ >=media-libs/mesa-10.2.8
+ || ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify )
+ >=sys-libs/ncurses-5.9-r3:5/5[tinfo]
+ >=sys-libs/zlib-1.2.8-r1
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXau-1.0.7-r1
+ >=x11-libs/libXdamage-1.1.4-r1
+ >=x11-libs/libXdmcp-1.1.1-r1
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ >=x11-libs/libXrender-0.9.8
+ >=x11-libs/libXxf86vm-1.1.3
+ >=x11-libs/libdrm-2.4.46
+ >=x11-libs/libxcb-1.9.1
+ >=x11-libs/libxshmfence-1.1"
+S=${WORKDIR}/${PN}
+PATCHES=( "${FILESDIR}/0001-use-java-home-before-bundled.patch" )
+
+src_prepare() {
+ eapply "${PATCHES[@]}"
+ eapply_user
+
+ # This is really a bundled jdk not a jre
+ rm -rf "${S}/jre" || die "Could not remove bundled jdk"
+
+ # Replace bundled jars with system
+ # has problems with newer jdom:0 not updated to jdom:2
+ cd "${S}/lib" || die
+ local JARS="commons-logging log4j"
+ local j
+ for j in ${JARS}; do
+ rm -v ${j/:*/}*.jar || die
+ java-pkg_jar-from ${j}
+ done
+
+ cd "${S}" || die
+
+ # bug 629404
+ echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio64.vmoptions || die
+ echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio.vmoptions || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+
+ insinto "${dir}"
+ doins -r *
+
+ # Replaced bundled jre with system vm/jdk
+ # This is really a bundled jdk not a jre
+ rm -rf "${ED%/}${dir}/jre" || die
+ dosym "../../etc/java-config-2/current-system-vm" "${dir}/jre"
+
+ fperms 755 "${dir}/bin/studio.sh" "${dir}"/bin/fsnotifier{,64}
+ fperms 755 "${dir}"/bin/*.py "${dir}"/bin/*.sh
+ chmod -R 755 "${ED%/}${dir}"/bin/lldb/{android,bin} || die
+ chmod 755 "${ED%/}${dir}"/gradle/gradle-*/bin/gradle || die
+
+ newicon "bin/studio.png" "${PN}.png"
+ make_wrapper ${PN} ${dir}/bin/studio.sh
+ make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" "StartupWMClass=jetbrains-studio"
+}