summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-05-15 10:17:48 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-05-15 10:18:21 +0100
commit0f3bfbf51f26652ed81a88717be7e5035350bda6 (patch)
tree4271d548c70715f94f8a1f73142b9b0d2c5b4414 /dev-util/anjuta
parentdev-python/immutables: Stabilize 0.17 arm64, #844793 (diff)
downloadgentoo-0f3bfbf51f26652ed81a88717be7e5035350bda6.tar.gz
gentoo-0f3bfbf51f26652ed81a88717be7e5035350bda6.tar.bz2
gentoo-0f3bfbf51f26652ed81a88717be7e5035350bda6.zip
dev-util/anjuta: Strip package down to base library for running apps
The project is now largely defunct upstream, so we only want to keep the base library for running applications such as app-pda/gtkpod. Fixes: https://bugs.gentoo.org/831521 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-util/anjuta')
-rw-r--r--dev-util/anjuta/anjuta-3.34.0-r2.ebuild53
-rw-r--r--dev-util/anjuta/files/3.34.0-minimal.patch72
-rw-r--r--dev-util/anjuta/metadata.xml24
3 files changed, 140 insertions, 9 deletions
diff --git a/dev-util/anjuta/anjuta-3.34.0-r2.ebuild b/dev-util/anjuta/anjuta-3.34.0-r2.ebuild
new file mode 100644
index 000000000000..fad8dc7ade3c
--- /dev/null
+++ b/dev-util/anjuta/anjuta-3.34.0-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Base library of defunct IDE for GNOME to run applications"
+HOMEPAGE="https://wiki.gnome.org/Apps/Anjuta https://gitlab.gnome.org/Archive/anjuta"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/gdl-3.5.5:3=
+ >=dev-libs/glib-2.34:2[dbus]
+ >=dev-libs/libxml2-2.4.23
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.10:3
+ x11-libs/pango
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-minimal.patch
+)
+
+LA="libanjuta-${PV%%.*}.la"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-debug \
+ --disable-introspection \
+ --disable-neon \
+ --disable-nls \
+ --disable-plugin-subversion \
+ --disable-serf \
+ --disable-static
+}
+
+src_compile() {
+ emake -C libanjuta/interfaces libanjuta-interfaces.la
+ emake -C libanjuta ${LA}
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C libanjuta install-am
+ emake DESTDIR="${D}" -C libanjuta/interfaces install-am
+ emake DESTDIR="${D}" -C src install-dist_anjuta_pixmapsDATA
+ rm -v "${ED}"/usr/$(get_libdir)/${LA} || die
+}
diff --git a/dev-util/anjuta/files/3.34.0-minimal.patch b/dev-util/anjuta/files/3.34.0-minimal.patch
new file mode 100644
index 000000000000..e3aae39fb377
--- /dev/null
+++ b/dev-util/anjuta/files/3.34.0-minimal.patch
@@ -0,0 +1,72 @@
+Stubs out parts of configure not needed for the base library to avoid
+additional build dependencies. Some can be avoided by setting environment
+variables, but not all.
+
+-- Chewi
+
+diff -Naur a/configure b/configure
+--- a/configure 2019-09-08 19:32:47.000000000 +0100
++++ b/configure 2022-05-15 09:45:11.158669066 +0100
+@@ -4894,6 +4894,7 @@
+ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+
+
++: <<'END'
+ for ac_prog in flex lex
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+@@ -5106,6 +5107,7 @@
+ as_fn_error $? "bison is required" "$LINENO" 5
+ ;;
+ esac
++END
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
+ ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+@@ -17726,6 +17728,7 @@
+ fi
+
+
++: <<'END'
+ pkg_failed=no
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for GDA" >&5
+ $as_echo_n "checking for GDA... " >&6; }
+@@ -19533,6 +19536,7 @@
+ $as_echo "#define ENABLE_PACKAGEKIT 1" >>confdefs.h
+
+ fi
++END
+
+ LIBANJUTA_CFLAGS='$(ANJUTA_CFLAGS) $(GDL_CFLAGS) $(DEPRECATED_FLAGS) -I$(top_srcdir) -I$(top_builddir)/libanjuta -DPACKAGE_PIXMAPS_DIR=\""$(datadir)/pixmaps/$(PACKAGE)"\" -DPACKAGE_LIB_DIR=\""$(pkglibdir)"\" -DPACKAGE_DATA_DIR=\""$(datadir)/$(PACKAGE)"\"'
+ LIBANJUTA_LIBS='$(top_builddir)/libanjuta/libanjuta-3.la'
+@@ -19624,6 +19628,7 @@
+
+
+
++: <<'END'
+ case "$am__api_version" in
+ 1.01234)
+ as_fn_error $? "Automake 1.5 or newer is required to use intltool" "$LINENO" 5
+@@ -20441,6 +20446,7 @@
+
+
+ ac_config_commands="$ac_config_commands po-directories"
++END
+
+
+
+@@ -24091,6 +24097,14 @@
+ am__EXEEXT_FALSE=
+ fi
+
++HAVE_PLUGIN_TERMINAL_TRUE='#'
++HAVE_PLUGIN_DEVHELP_TRUE='#'
++HAVE_PLUGIN_GLADE_TRUE='#'
++ENABLE_GLADE_CATALOG_TRUE='#'
++HAVE_SQLITE_TRUE='#'
++ENABLE_VALA_TRUE='#'
++HAVE_PYTHON_TRUE='#'
++
+ if test -z "${MAINTAINER_MODE_TRUE}" && test -z "${MAINTAINER_MODE_FALSE}"; then
+ as_fn_error $? "conditional \"MAINTAINER_MODE\" was never defined.
+ Usually this means the macro was only invoked conditionally." "$LINENO" 5
diff --git a/dev-util/anjuta/metadata.xml b/dev-util/anjuta/metadata.xml
index 1a2b49cac930..c3c257320f5c 100644
--- a/dev-util/anjuta/metadata.xml
+++ b/dev-util/anjuta/metadata.xml
@@ -1,13 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>chewi@gentoo.org</email>
- <name>James Le Cuirot</name>
- </maintainer>
- <use>
- <flag name="devhelp">Enable devhelp integration</flag>
- <flag name="glade">Build glade plugin for anjuta</flag>
- <flag name="terminal">Enable terminal plugin based on <pkg>x11-libs/vte</pkg></flag>
- </use>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <use>
+ <flag name="devhelp">Enable devhelp integration</flag>
+ <flag name="glade">Build glade plugin for anjuta</flag>
+ <flag name="terminal">Enable terminal plugin based on <pkg>x11-libs/vte</pkg></flag>
+ </use>
+ <longdescription lang="en">
+ This package used to build the entire Anjuta IDE for GNOME with all its
+ plugins. The project is now largely defunct, so the package has been
+ reduced to the base library, allowing applications built on Anjuta to
+ still be run.
+ </longdescription>
</pkgmetadata>