summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/apitrace/files/apitrace-4.0-multilib.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/apitrace/files/apitrace-4.0-multilib.patch')
-rw-r--r--dev-util/apitrace/files/apitrace-4.0-multilib.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/apitrace/files/apitrace-4.0-multilib.patch b/dev-util/apitrace/files/apitrace-4.0-multilib.patch
new file mode 100644
index 000000000000..6ad78c7cde08
--- /dev/null
+++ b/dev-util/apitrace/files/apitrace-4.0-multilib.patch
@@ -0,0 +1,59 @@
+Upstream commit to find wrappers in lib64 directory.
+
+commit 3f9c2ecf18d8fa37fad5a7062f80952692eaa8e7
+Author: Alexander Monakov <amonakov@ispras.ru>
+Date: Wed Oct 16 20:51:47 2013 +0400
+
+ cli: use $LIB to handle multilib automagically on glibc
+
+--- apitrace/cli/CMakeLists.txt
++++ apitrace/cli/CMakeLists.txt
+@@ -31,6 +31,7 @@ target_link_libraries (apitrace
+ ${ZLIB_LIBRARIES}
+ ${SNAPPY_LIBRARIES}
+ ${GETOPT_LIBRARIES}
++ dl
+ )
+
+ if (NOT CMAKE_CROSSCOMPILING)
+--- apitrace/cli/cli_resources.cpp
++++ apitrace/cli/cli_resources.cpp
+@@ -32,6 +32,20 @@
+
+ #include "cli_resources.hpp"
+
++#ifdef __GLIBC__
++
++#include <dlfcn.h>
++
++static bool
++tryLib(const os::String &path)
++{
++ void *handle = dlopen(path.str(), RTLD_LAZY);
++ bool exists = (handle != NULL);
++ if (exists)
++ dlclose(handle);
++ return exists;
++}
++#endif
+
+ os::String
+ findProgram(const char*programFilename)
+@@ -76,6 +90,17 @@ findWrapper(const char *wrapperFilename)
+ return wrapperPath;
+ }
+
++#ifdef __GLIBC__
++ // We want to take advantage of $LIB dynamic string token expansion in
++ // glibc dynamic linker to handle multilib layout for us
++ wrapperPath = processDir;
++ wrapperPath.join("../$LIB/apitrace/wrappers");
++ wrapperPath.join(wrapperFilename);
++ if (tryLib(wrapperPath)) {
++ return wrapperPath;
++ }
++#endif
++
+ // Try relative install directory
+ wrapperPath = processDir;
+ #if defined(_WIN32)