summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-05-06 10:36:36 +0200
committerMichael Weber <xmw@gentoo.org>2016-05-06 10:40:26 +0200
commit4eec892b2e50ceabc5b6370e122ee8387f739696 (patch)
treed0d93bf9096f53520aefaac717619cc5cca87b06 /dev-util/apitrace/files
parentapp-emacs/nxml-gentoo-schemas: Remove old. (diff)
downloadgentoo-4eec892b2e50ceabc5b6370e122ee8387f739696.tar.gz
gentoo-4eec892b2e50ceabc5b6370e122ee8387f739696.tar.bz2
gentoo-4eec892b2e50ceabc5b6370e122ee8387f739696.zip
dev-util/apitrace: Version bump by EoD (bug 559566).
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/apitrace/files')
-rw-r--r--dev-util/apitrace/files/apitrace-7.1-disable-multiarch.patch35
-rw-r--r--dev-util/apitrace/files/apitrace-7.1-docs-install.patch23
-rw-r--r--dev-util/apitrace/files/apitrace-7.1-glxtrace-only.patch32
-rw-r--r--dev-util/apitrace/files/apitrace-7.1-snappy-license.patch11
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-util/apitrace/files/apitrace-7.1-disable-multiarch.patch b/dev-util/apitrace/files/apitrace-7.1-disable-multiarch.patch
new file mode 100644
index 000000000000..53d470d8705d
--- /dev/null
+++ b/dev-util/apitrace/files/apitrace-7.1-disable-multiarch.patch
@@ -0,0 +1,35 @@
+respect the libdir cmake already set up for us instead of using debian-specific multiarch paths
+
+--- apitrace-7.1/CMakeLists.txt
++++ apitrace-7.1/CMakeLists.txt
+@@ -359,15 +359,6 @@
+ ##############################################################################
+ # Installation directories
+
+-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
+- # Debian multiarch support
+- execute_process(COMMAND dpkg-architecture -qDEB_HOST_MULTIARCH
+- OUTPUT_VARIABLE ARCH_SUBDIR
+- ERROR_QUIET
+- OUTPUT_STRIP_TRAILING_WHITESPACE
+- )
+-endif()
+-
+ if (WIN32 OR APPLE)
+ # On Windows/MacOSX, applications are usually installed on a directory of
+ # their own
+@@ -376,12 +367,8 @@
+ set (LIB_ARCH_INSTALL_DIR lib)
+ else ()
+ set (DOC_INSTALL_DIR share/doc/${CMAKE_PROJECT_NAME})
+- set (LIB_INSTALL_DIR lib${LIB_SUFFIX}/${CMAKE_PROJECT_NAME})
+- if (ARCH_SUBDIR)
+- set (LIB_ARCH_INSTALL_DIR lib/${ARCH_SUBDIR}/${CMAKE_PROJECT_NAME})
+- else ()
+- set (LIB_ARCH_INSTALL_DIR lib${LIB_SUFFIX}/${CMAKE_PROJECT_NAME})
+- endif ()
++ set (LIB_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/${CMAKE_PROJECT_NAME})
++ set (LIB_ARCH_INSTALL_DIR ${LIB_INSTALL_DIR})
+ endif ()
+
+ set (SCRIPTS_INSTALL_DIR ${LIB_INSTALL_DIR}/scripts)
diff --git a/dev-util/apitrace/files/apitrace-7.1-docs-install.patch b/dev-util/apitrace/files/apitrace-7.1-docs-install.patch
new file mode 100644
index 000000000000..9fdc04ffe996
--- /dev/null
+++ b/dev-util/apitrace/files/apitrace-7.1-docs-install.patch
@@ -0,0 +1,23 @@
+--- apitrace-7.1/CMakeLists.txt
++++ apitrace-7.1/CMakeLists.txt
+@@ -553,20 +553,6 @@
+ ##############################################################################
+ # Packaging
+
+-install (
+- FILES
+- README.markdown
+- docs/BUGS.markdown
+- docs/NEWS.markdown
+- docs/USAGE.markdown
+- DESTINATION ${DOC_INSTALL_DIR}
+-)
+-install (
+- FILES LICENSE
+- DESTINATION ${DOC_INSTALL_DIR}
+- RENAME LICENSE.txt
+-)
+-
+ set (CPACK_PACKAGE_VERSION_MAJOR "7")
+ set (CPACK_PACKAGE_VERSION_MINOR "0")
+
diff --git a/dev-util/apitrace/files/apitrace-7.1-glxtrace-only.patch b/dev-util/apitrace/files/apitrace-7.1-glxtrace-only.patch
new file mode 100644
index 000000000000..91867affca26
--- /dev/null
+++ b/dev-util/apitrace/files/apitrace-7.1-glxtrace-only.patch
@@ -0,0 +1,32 @@
+Allow building of just glxtrace library for ebuilds without GUI tools.
+
+Updated from 5.0 version of patch to apply against 7.1.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -44,6 +44,8 @@
+
+ option (ENABLE_FRAME_POINTER "Disable frame pointer omission" ON)
+
++option (BUILD_LIB_ONLY "Build the glxtrace library only" OFF)
++
+ # Proprietary Linux games often ship their own libraries (zlib, libstdc++,
+ # etc.) in order to ship a single set of binaries across multiple
+ # distributions. Given that apitrace wrapper modules will be loaded into those
+--- a/retrace/CMakeLists.txt
++++ b/retrace/CMakeLists.txt
+@@ -12,6 +12,8 @@
+
+ add_definitions (-DRETRACE)
+
++if (NOT BUILD_LIB_ONLY)
++
+ add_custom_command (
+ OUTPUT glretrace_gl.cpp
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/glretrace.py > ${CMAKE_CURRENT_BINARY_DIR}/glretrace_gl.cpp
+@@ -368,3 +370,5 @@
+ install (TARGETS d3dretrace RUNTIME DESTINATION bin)
+ install_pdb (d3dretrace DESTINATION bin)
+ endif ()
++
++endif (NOT BUILD_LIB_ONLY)
diff --git a/dev-util/apitrace/files/apitrace-7.1-snappy-license.patch b/dev-util/apitrace/files/apitrace-7.1-snappy-license.patch
new file mode 100644
index 000000000000..2b211dc5ddb7
--- /dev/null
+++ b/dev-util/apitrace/files/apitrace-7.1-snappy-license.patch
@@ -0,0 +1,11 @@
+--- apitrace-7.1/thirdparty/snappy/CMakeLists.txt
++++ apitrace-7.1/thirdparty/snappy/CMakeLists.txt
+@@ -16,8 +16,3 @@
+ snappy-c.cc
+ )
+
+-install (
+- FILES COPYING
+- DESTINATION ${DOC_INSTALL_DIR}
+- RENAME LICENSE-snappy.txt
+-)