summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-19 12:09:48 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-19 12:09:48 -0500
commit30a5c9c3efa3ef88f8fea9616cb9b8dcc33ac904 (patch)
tree15011b9195cfb87c2ce2f9c00fad05ecab512b2f /dev-util/artifactory-bin
parentsci-physics/espresso: added live ebuild (diff)
downloadgentoo-30a5c9c3efa3ef88f8fea9616cb9b8dcc33ac904.tar.gz
gentoo-30a5c9c3efa3ef88f8fea9616cb9b8dcc33ac904.tar.bz2
gentoo-30a5c9c3efa3ef88f8fea9616cb9b8dcc33ac904.zip
dev-util/artifactory-bin: version bump, 4.9.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util/artifactory-bin')
-rw-r--r--dev-util/artifactory-bin/Manifest1
-rw-r--r--dev-util/artifactory-bin/artifactory-bin-4.9.1.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-util/artifactory-bin/Manifest b/dev-util/artifactory-bin/Manifest
index 57c95ac4b947..970964546430 100644
--- a/dev-util/artifactory-bin/Manifest
+++ b/dev-util/artifactory-bin/Manifest
@@ -4,3 +4,4 @@ DIST artifactory-4.8.0.zip 41084705 SHA256 2de13962ad1e6f4f1537e1fd86b6e70da6afa
DIST artifactory-4.8.1.zip 40949993 SHA256 12218335d6f45d1ffca0bce2cbe636cf4d8c9fe71747dc9ce04a7be78acd9529 SHA512 0873003d307187adcaff77ab52daebdcffbc96748f2203ead169148fdb3860fd90d28c68bacf58fc928c5608303d5d4fdb839ed7d5c6f5a4ddca573e91946c85 WHIRLPOOL a6c38a5d38ea3034c578b47b7021146cb960e25833155606d9cd2d301c644b400af81a28c4779caec82ae0296f04185225d3bb6cee06dffdb224937430df390a
DIST artifactory-4.8.2.zip 40938623 SHA256 6821196157e9cba70f99c0fe960971333455327cc54139f310edc30e88dd2392 SHA512 9bf40b945c943a08a92f5e1fac3a75ab923fcc57e04a7e845e8fb75a0825199b2ce6f3d90c58669777388c400c953873123e8de76a0244786d4106f6b426a6bc WHIRLPOOL 571654b43cc36f02bb731e46ae89b37146c2e785419f620226363a7f38b11cb8e54667d2faff1c922ee2e8437c18d05c37c7afeb395cf59328a31ad8ff1b52e8
DIST artifactory-4.9.0.zip 41020300 SHA256 c97c2293c676c9ca5e3c0c64b2a02e2565427f3fe2cf5aa3e0518f6b541a23e5 SHA512 266891f4d1b580f4f0764dee75f452cc73d76287565e8d89a84b912bb58d816e08369b56a1cf6858d23aefbf95d347386b9a6f4dc451d8ed80635b972680911d WHIRLPOOL 4a485c80d4f5e68ac19616569e14fb4623329aebf7d1724cccce4d2820dd00f26d97a2a1afc69f8df39af3a39db87e6098c9739f9c51e5b5b6f19e18835729f3
+DIST artifactory-4.9.1.zip 41017240 SHA256 d69635a02c2cdf7d19b593dd5378baf77552769c06ceb0900cb2177f61594d0d SHA512 4001128fb7d4cb38417c96745a0795434498afe2e44d316748982fee4afde5076f8c05062f1712f169f260b2df3bd7322e845846d32acef0a65aa8385e44b1eb WHIRLPOOL 1d781e82505a26b42e27d90f540d52d5eff22d25feff9ef8118ca32172b793509d0b2452506ac360833ce88a05e6ee9bb95d22f1c7c186fda624004b1a4ffe24
diff --git a/dev-util/artifactory-bin/artifactory-bin-4.9.1.ebuild b/dev-util/artifactory-bin/artifactory-bin-4.9.1.ebuild
new file mode 100644
index 000000000000..211224df317c
--- /dev/null
+++ b/dev-util/artifactory-bin/artifactory-bin-4.9.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Using a binary ebuild until a source ebuild is doable.
+# This was previously blocked by two major bugs upstream:
+# A lack of documented build instructions - https://www.jfrog.com/jira/browse/RTFACT-8960
+# A lack of source releases - https://www.jfrog.com/jira/browse/RTFACT-8961
+# Upstream now releases source and instructions (yay!), but most of artifactory's
+# dependencies are not in portage yet.
+
+EAPI=6
+
+inherit user
+
+MY_P="${P/-bin}"
+MY_PN="${PN/-bin}"
+MY_PV="${PV/-bin}"
+
+DESCRIPTION="The world's most advanced repository manager for maven"
+HOMEPAGE="http://www.jfrog.org/products.php"
+SRC_URI="https://bintray.com/artifact/download/jfrog/artifactory/jfrog-artifactory-oss-${MY_PV}.zip -> ${MY_P}.zip"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="ssl"
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=">=virtual/jdk-1.8
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_PN}-oss-${MY_PV}"
+
+pkg_setup() {
+ enewgroup artifactory
+ enewuser artifactory -1 /bin/sh -1 artifactory
+}
+
+src_prepare() {
+ default
+
+ if use ssl ; then
+ cp "${FILESDIR}/artifactory.xml" tomcat/conf/Catalina/localhost/artifactory.xml || die
+ cp "${FILESDIR}/server.xml" tomcat/conf/server.xml || die
+ fi
+
+ # Reverse https://www.jfrog.com/jira/browse/RTFACT-7123
+ sed -i -e "s%artifactory.repo.global.disabled=true%artifactory.repo.global.disabled=false%g;" \
+ etc/artifactory.system.properties || die
+
+ # See FIXME in src_install(), this can probably go away,
+ # but catalina.sh may need to be fixed for that:
+ sed -i -e "s%/etc/opt/jfrog/artifactory/default%/etc/conf.d/${MY_PN}%g;" \
+ misc/service/setenv.sh || die
+}
+
+src_install() {
+ local ARTIFACTORY_HOME="/opt/artifactory"
+ local TOMCAT_HOME="${ARTIFACTORY_HOME}/tomcat"
+
+ insinto ${ARTIFACTORY_HOME}
+ doins -r etc logs misc tomcat webapps
+
+ dodir /etc/opt/jfrog
+ dosym ${ARTIFACTORY_HOME}/etc /etc/opt/jfrog/artifactory
+
+ dosym ${ARTIFACTORY_HOME}/logs /var/log/artifactory
+
+ exeinto ${ARTIFACTORY_HOME}/bin
+ doexe bin/*
+
+ # FIXME: this is called by catalina.sh (it echoes the variables before starting
+ # artifactory, as well as makes sure log dir, etc. exists). Those directories
+ # could probably be moved to the ebuild and the script removed from catalina.sh
+ # without consequence (and quieter starts). Would need to check if CATALINA_*
+ # variables are actually used anywhere (from reading code don't appear to be
+ # actually needed)
+ exeinto ${TOMCAT_HOME}/bin
+ doexe misc/service/setenv.sh
+ doexe tomcat/bin/*
+
+ keepdir ${ARTIFACTORY_HOME}/backup
+ keepdir ${ARTIFACTORY_HOME}/data
+ keepdir ${ARTIFACTORY_HOME}/run
+ keepdir ${ARTIFACTORY_HOME}/work
+ keepdir ${TOMCAT_HOME}/logs/catalina
+ keepdir ${TOMCAT_HOME}/temp
+ keepdir ${TOMCAT_HOME}/work
+ keepdir /var/opt/jfrog/artifactory/run
+
+ newconfd "${FILESDIR}/confd" ${MY_PN}
+ newinitd "${FILESDIR}/initd" ${MY_PN}
+
+ fowners -R artifactory:artifactory ${ARTIFACTORY_HOME}
+ fperms -R u+w ${TOMCAT_HOME}/work
+}