summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-12-18 16:51:02 -0600
committerAustin English <wizardedit@gentoo.org>2017-12-18 16:51:17 -0600
commitefa8855df353466dc7605a79d0e4138b62372e2a (patch)
tree1699c49b05f16d2b8cb33a6de23f12e3c8f1c5a3 /dev-util/artifactory-bin
parentx11-libs/libva-intel-driver: x11-libs/libva is slotted (diff)
downloadgentoo-efa8855df353466dc7605a79d0e4138b62372e2a.tar.gz
gentoo-efa8855df353466dc7605a79d0e4138b62372e2a.tar.bz2
gentoo-efa8855df353466dc7605a79d0e4138b62372e2a.zip
dev-util/artifactory-bin: version bump, 5.6.3
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-util/artifactory-bin')
-rw-r--r--dev-util/artifactory-bin/Manifest1
-rw-r--r--dev-util/artifactory-bin/artifactory-bin-5.6.3.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-util/artifactory-bin/Manifest b/dev-util/artifactory-bin/Manifest
index d3996dc2cfb1..aa7cf59e0a1c 100644
--- a/dev-util/artifactory-bin/Manifest
+++ b/dev-util/artifactory-bin/Manifest
@@ -6,3 +6,4 @@ DIST artifactory-5.4.6.zip 76857888 BLAKE2B 04185e4c585a6e8121b9b6d78a4565c51073
DIST artifactory-5.5.1.zip 77406287 BLAKE2B be60fbbc3b8c61fc9d1a7272889219de7ea4e5b8c760afaa7e0003f6bff48d41783f76d62ac64b81ffa42393a265ed184ad4a4a23789dc79955907290035dae1 SHA512 7327135be0c2a08dd97c575b05be1c3e4be99b38354864313d201334d3276912bcff0c6b0743fb83a2433a82fc8fcf4ec43e98f4183287fc34f1807342abedf8
DIST artifactory-5.5.2.zip 77438814 BLAKE2B b77d9348fbae8bf871e4fb6716e2a9d357cd0d268d65360ec7509b0999db78a8b80f68eb22cbbc0a85ee2980fbc72c7aa390a60c8129451506441d7cbfd9f776 SHA512 fd052e66316ec050599f6262274cdf5232ebb1385fedd2c19c6ba8e3dca0d9fe86d7a89fddbb8974b28e0f9dc3d7ccda1aac6b3f9159f0b77bfc51873ffd5e3b
DIST artifactory-5.6.2.zip 91577071 BLAKE2B 1f9687bef239519171bdb28fb033368e5dea10186ef350c7ee7d9e4a33ce99c5e965692d8052d82454c83f42c84e79c18edafbb98540da4b818b65b577a9ac72 SHA512 b4bde9bcf53d2af6901a8e80827f3b09d685a8bbe7073badad586401b6881d046e5cade4165fa68843e981dea2912374c187518e29ab1ee86d3d0fac134a54f0
+DIST artifactory-5.6.3.zip 91592176 BLAKE2B 1214bac4d5bd6f15915e05a2e42de4b6b55b885210fa06ee4b4b63599b8f3c13c6fe46a04569e790ea6e274c4837a09b260736412805119e7f93f7867be8e421 SHA512 a2348b8667a1d936e90dc6fd42e3967f63cc88cc99bf425ea26731ff4c54f0177ea386c5b19be97a4ac8f89ce41e65237d14593112b38656d60ada45d3b62371
diff --git a/dev-util/artifactory-bin/artifactory-bin-5.6.3.ebuild b/dev-util/artifactory-bin/artifactory-bin-5.6.3.ebuild
new file mode 100644
index 000000000000..242019ded03b
--- /dev/null
+++ b/dev-util/artifactory-bin/artifactory-bin-5.6.3.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Using a binary ebuild until a source ebuild is doable.
+# This was previously blocked by two major bugs upstream:
+# A lack of documented build instructions - https://www.jfrog.com/jira/browse/RTFACT-8960
+# A lack of source releases - https://www.jfrog.com/jira/browse/RTFACT-8961
+# Upstream now releases source and instructions (yay!), but most of artifactory's
+# dependencies are not in portage yet.
+
+EAPI=6
+
+inherit user
+
+MY_P="${P/-bin}"
+MY_PN="${PN/-bin}"
+MY_PV="${PV/-bin}"
+
+DESCRIPTION="The world's most advanced repository manager for maven"
+HOMEPAGE="http://www.jfrog.org/products.php"
+SRC_URI="https://bintray.com/artifact/download/jfrog/artifactory/jfrog-artifactory-oss-${MY_PV}.zip -> ${MY_P}.zip"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="ssl"
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=">=virtual/jdk-1.8
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_PN}-oss-${MY_PV}"
+
+pkg_setup() {
+ enewgroup artifactory
+ enewuser artifactory -1 /bin/sh -1 artifactory
+}
+
+limitsdfile=40-${MY_PN}.conf
+
+print_limitsdfile() {
+ printf "# Start of ${limitsdfile} from ${P}\n\n"
+ printf "@${MY_PN}\t-\tnofile\t32000\n"
+ printf "\n# End of ${limitsdfile} from ${P}\n"
+}
+
+src_prepare() {
+ default
+
+ if use ssl ; then
+ cp "${FILESDIR}/artifactory.xml" tomcat/conf/Catalina/localhost/artifactory.xml || die
+ cp "${FILESDIR}/server.xml" tomcat/conf/server.xml || die
+ fi
+
+ # Reverse https://www.jfrog.com/jira/browse/RTFACT-7123
+ sed -i -e "s%artifactory.repo.global.disabled=true%artifactory.repo.global.disabled=false%g;" \
+ etc/artifactory.system.properties || die
+
+ # See FIXME in src_install(), this can probably go away,
+ # but catalina.sh may need to be fixed for that:
+ sed -i -e "s%/etc/opt/jfrog/artifactory/default%/etc/conf.d/${MY_PN}%g;" \
+ misc/service/setenv.sh || die
+
+ einfo "Generating ${limitsdfile}"
+ print_limitsdfile > "${S}/${limitsdfile}"
+}
+
+src_install() {
+ local ARTIFACTORY_HOME="/opt/artifactory"
+ local TOMCAT_HOME="${ARTIFACTORY_HOME}/tomcat"
+
+ insinto ${ARTIFACTORY_HOME}
+ doins -r etc logs misc tomcat webapps
+
+ dodir /etc/opt/jfrog
+ dosym ${ARTIFACTORY_HOME}/etc /etc/opt/jfrog/artifactory
+
+ dosym ${ARTIFACTORY_HOME}/logs /var/log/artifactory
+
+ exeinto ${ARTIFACTORY_HOME}/bin
+ doexe bin/*
+
+ # FIXME: this is called by catalina.sh (it echoes the variables before starting
+ # artifactory, as well as makes sure log dir, etc. exists). Those directories
+ # could probably be moved to the ebuild and the script removed from catalina.sh
+ # without consequence (and quieter starts). Would need to check if CATALINA_*
+ # variables are actually used anywhere (from reading code don't appear to be
+ # actually needed)
+ exeinto ${TOMCAT_HOME}/bin
+ doexe misc/service/setenv.sh
+ doexe tomcat/bin/*
+
+ keepdir ${ARTIFACTORY_HOME}/backup
+ keepdir ${ARTIFACTORY_HOME}/data
+ keepdir ${ARTIFACTORY_HOME}/run
+ keepdir ${ARTIFACTORY_HOME}/work
+ keepdir ${TOMCAT_HOME}/logs/catalina
+ keepdir ${TOMCAT_HOME}/temp
+ keepdir ${TOMCAT_HOME}/work
+ keepdir /var/opt/jfrog/artifactory/run
+
+ newconfd "${FILESDIR}/confd" ${MY_PN}
+ newinitd "${FILESDIR}/initd-r3" ${MY_PN}
+
+ fowners -R artifactory:artifactory ${ARTIFACTORY_HOME}
+ fperms -R u+w ${TOMCAT_HOME}/work
+
+ insinto /etc/security/limits.d
+ doins "${S}/${limitsdfile}"
+}